flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Harui (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLEX-33409) TLF crashes when hypens are shown in a multi span textFlow
Date Wed, 21 Aug 2013 20:03:51 GMT

    [ https://issues.apache.org/jira/browse/FLEX-33409?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13746780#comment-13746780
] 

Alex Harui edited comment on FLEX-33409 at 8/21/13 8:02 PM:
------------------------------------------------------------

FlowLeafElement was expecting the computedFormat to be non-null.  Guarded against that and
now the 19th Enter appears to be successful.  But it wouldn't surprise me of there are other
issues waiting to be found.
                
      was (Author: aharui):
    FlowLeafElement was expecting the computedFormat to be non-null.  Guarded against that
and now the 19th Enter appears to be successful.  But it wouldn't surprise me of there are
other errors.
                  
> TLF crashes when hypens are shown in a multi span textFlow
> ----------------------------------------------------------
>
>                 Key: FLEX-33409
>                 URL: https://issues.apache.org/jira/browse/FLEX-33409
>             Project: Apache Flex
>          Issue Type: Bug
>    Affects Versions: Adobe Flex SDK 4.6 (Release)
>         Environment: TLF editing
>            Reporter: Woodwing Developer
>            Assignee: Alex Harui
>            Priority: Blocker
>              Labels: TLF, crash, editing, hyphen, span, textflow
>         Attachments: BaseCompose.as, ComposeState.as, FLEX33409.patch, FlowLeafElement.as,
Test.fxp, textLayout.swc
>
>
> When soft hyphens are used and shown, in a textFlow with 2 or more spans, TLF crashes
when typing.
> Import the underlying text flow xml. Resize the text area until the hyphen is visible.
Then start typing AFTER the hypened word, also pressing the enter key. TLF crashes.
> Sample textFLow (if the soft hyphen is not show, insert a new one in the appropriate
word):
>   <TextFlow color="#000000" fontSize="12" lineHeight="14" paddingBottom="0" paddingLeft="10"
paddingRight="10" paddingTop="0" whiteSpaceCollapse="preserve" version="2.0.0" xmlns="http://ns.adobe.com/textLayout/2008">
>     <p>
>       <span backgroundColor="#ffffff" textDecoration="underline">First Span</span>
>       <span backgroundColor="#ffffff" textDecoration="none"> Second span. This
text has a hypen in the next long word LongWord­WithAHyphen. Make sure the hypen is shown!
Then start typing and pressing enter till TLF crashes (should happen fast enough)</span>
>   </p>
>   </TextFlow>
> It seems that the textLine is damaged but the text engine fails to recompose the line
properly.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message