flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik de Bruin <e...@ixsoftware.nl>
Subject Re: OSMF download fails when running 'ant'
Date Thu, 28 Sep 2017 12:53:38 GMT
When I got to sourceforge directly, I see the download link as:

https://sourceforge.net/adobe/flexsdk/code/4/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw

Which is different from the one in the build script:

https://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw

I hesitate to change the URL in the build script as I don't know if it
changed at sourceforge or if the link in the script is a workaround for
e.g. a redirect at the source when running on the command line?

Thanks,

EdB



On Thu, Sep 28, 2017 at 2:49 PM, Erik de Bruin <erik@ixsoftware.nl> wrote:

> Hi,
>
> When I run 'ant' on a fresh copy of the Flex SDK repo, I get the following
> error:
>
> [error]
> download-osmf-swc:
>       [get] Getting: https://sourceforge.net/adobe/
> flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw
>       [get] To: /Users/erik/Desktop/royale/flex-sdk/in/osmf.swc
>       [get] Error getting https://sourceforge.net/adobe/
> flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw to
> /Users/erik/Desktop/royale/flex-sdk/in/osmf.swc
>
> double-check-file:
>      [echo] Need file: ${still_no_file}
>
> get-from-cache-if-needed:
>
> fail-if-not-found:
>
> BUILD FAILED
> /Users/erik/Desktop/royale/flex-sdk/build.xml:157: The following error
> occurred while executing this line:
> /Users/erik/Desktop/royale/flex-sdk/frameworks/build.xml:100: The
> following error occurred while executing this line:
> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:105: The
> following error occurred while executing this line:
> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:117: The
> following error occurred while executing this line:
> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:422:
> osmf.swc could not be downloaded or found in cache
> [/error]
>
> I think I remember this happening way back when as well, but I don't
> remember the workaround/fix. Help?
>
> Thanks,
>
> EdB
>
>
>
> --
> Ix Multimedia Software
>
> Jan Luykenstraat 27
> 3521 VB Utrecht
>
> T. 06-51952295 <06%2051952295>
> I. www.ixsoftware.nl
>



-- 
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message