flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Tynjala <joshtynj...@gmail.com>
Subject Re: [Flex JS] Flex SDK Installer always get stuck at "Finish uncompressing"
Date Mon, 28 Aug 2017 15:44:11 GMT
VSCode checks if an SDK contains two directories named "bin" and
"frameworks", and it requires either "flex-sdk-description.xml" or
"air-sdk-description.xml" in the root of the SDK.

One change that I could make is to allow "bin" to be missing if "js/bin"
exists instead.

The parts of Moonshine that I've worked on should have these same
requirements, but there may be some other requirements elsewhere in the

- Josh

On Mon, Aug 28, 2017 at 8:31 AM, Alex Harui <aharui@adobe.com.invalid>

> AIR and Flash are already technically prerequisites, but folks found it so
> inconvenient compared to the old Adobe distributions that Om and others
> created the Installer to automate fetching the Flash/AIR bits.
> Flash Builder, and maybe some other IDEs, expect AIR and Flash files in
> the SDK folder.  Anyone using Maven and only using an IDE as a text editor
> without much code intelligence can just use Maven to get the things they
> need.
> Using Ant to install the SDK worked the last time I tried it.
> I'm not sure what dependencies VSCode Extensions and Moonshine expect, but
> if they can live without Flash/AIR then it is possible to put together a
> JS-only package.
> And anyone who wants to become an authorized Adobe distributor can sign up
> with Adobe to distribute the Flash/AIR SDKs and make packages like Adobe
> did.  But Apache probably shouldn't since that is distributing stuff that
> isn't open source.
> -Alex
> On 8/28/17, 7:23 AM, "Olaf Krueger" <post@olafkrueger.net> wrote:
> >Hmm... if we just would like to target JS, do we still need AIR and
> >playerglobal.swc?
> >If not, maybe we could provide a FlexJS "JS only" version?
> >
> >Maybe another approach could be to declare AIR as a prerequisite?
> >
> >Thanks,
> >Olaf
> >
> >
> >
> >
> >--
> >View this message in context:
> >https://na01.safelinks.protection.outlook.com/?url=
> http%3A%2F%2Fapache-fle
> >x-development.2333347.n4.nabble.com%2FFlex-JS-Flex-SDK-
> Installer-always-ge
> >t-stuck-at-Finish-uncompressing-tp63989p63994.
> html&data=02%7C01%7C%7Cd392a
> >411c104483719ef08d4ee206ef6%7Cfa7b1b5a7b34438794aed2c178de
> cee1%7C0%7C0%7C6
> >36395270455882491&sdata=J%2F2HjEqxGEGjfgJRS9Z8HgNEkabQ6k
> 3%2BfghmAssykVc%3D
> >&reserved=0
> >Sent from the Apache Flex Development mailing list archive at Nabble.com.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message