flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From remya <remya...@gmail.com>
Subject Flash application video is getting blank in chrome browser
Date Sat, 19 Aug 2017 04:45:57 GMT
Once updated chrome version from 59 to 60.0.3112.101 (Official Build)
(64-bit), flash web application is not listing camera and microphone driver
list. It's displaying empty list. To solve this issue I have stored
Camera.names in an array and named such that Camera 1, Camera 2 etc but
while starting the video it's getting blank screen .

Below is the sample code which I have used for

private var videodriver:Array = new Array();
private var arrVideoDriver:ArrayCollection = new ArrayCollection();

private function init():void{
	videodriver=Camera.names;
				
	for (var i=0; i < videodriver.length; i++){
		arrVideoDriver.addItem("Camera " + (i+1));
	}
				
	camSelect.dataProvider = arrVideoDriver;
}
private function onStart():void{
	var camArray:Array = new Array();
	camArray = Camera.names;
	var i:int;
	if(videoDeviceString == ""){
		Alert.show("Please select camera");
		return;
	}
	for (i=0; i < camArray.length; i++){
		if (camSelect.s
<http://apache-flex-development.2333347.n4.nabble.com/file/n63915/videoBlankScreen.jpg>
electedIndex == i) { 
		break;
	      }
	}
	video=new Video();
	video.width=vidDisplay.width;
	video.height=vidDisplay.height;
	camTemp=Camera.getCamera(i.toString());
	video.attachCamera(camTemp);
	video.smoothing=true;
	vidDisplay.addChild(video);
}



--
View this message in context: http://apache-flex-development.2333347.n4.nabble.com/Flash-application-video-is-getting-blank-in-chrome-browser-tp63915.html
Sent from the Apache Flex Development mailing list archive at Nabble.com.

Mime
View raw message