flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harbs <harbs.li...@gmail.com>
Subject Re: dual issues
Date Mon, 05 Jun 2017 17:49:59 GMT
In compilerOptions.

Here’s my tasks.json file:
{
	// See https://go.microsoft.com/fwlink/?LinkId=733558
	// for the documentation about the tasks.json format
	"version": "0.1.0",
	"command": "asconfigc",
	"isShellCommand": true,
	"args": [
		"--flexHome=/FlexSDK/FlexJSNightly"
	],
	"windows": {
        "args": [
			"--flexHome=C:\\dev\\flexjs_builds\\nightly_07"
		]
    },
	"showOutput": "always"
}

asconfig.json:
{
    "config": "flex",
    "compilerOptions": {
        "debug": true,
        "targets": ["JSFlex"],
        "source-map": false,
        "library-path": [
            "lib"
        ],
        "external-library-path": [
        "typedefs"
        ]
    },
    "copySourcePathAssets": true,
    "additionalOptions": "-remove-circulars -js-output-optimization=skipAsCoercions -html-template=src/resources/mdl-js-index-template.html
-js-external-library-path+=typedefs -js-library-path+=lib",
    "files":
    [
        "src/PortedPrintUI.mxml"
    ]
}

I’m having other issues after switching to dual as well. Maybe I should show you…

Harbs

> On Jun 5, 2017, at 4:31 PM, Josh Tynjala <joshtynjala@gmail.com> wrote:
> 
> Are you setting debug in an argument passed to asconfigc, like this?
> 
> asconfigc --debug=false
> 
> Or is it specified in asconfig.json in the compilerOptions section?
> 
> Both will work, but the asconfigc command line option will always override
> whatever is in asconfig.json. In VSCode, the generated tasks.json now
> defaults to --debug=true, so that could take precedence if you're trying to
> set debug to false in asconfig.json. You might want to double-check both
> locations (asconfig.json and tasks.json).
> 
> - Josh
> 
> On Sun, Jun 4, 2017 at 2:08 AM, Harbs <harbs.lists@gmail.com> wrote:
> 
>> I’m seeing similar times using both ant and asconfig for debug. (Both are
>> good.)
>> 
>> asconfig is not compiling a release build at all — even if I specify
>> debug=false.
>> 
>> I have not tried with Maven.
>> 
>>> On Jun 4, 2017, at 12:06 PM, Justin Mclean <justin@classsoftware.com>
>> wrote:
>>> 
>>> Hi,
>>> 
>>>> Justin you are compiling by Maven ?
>>> 
>>> Yep and Debug builds are noticeably slower for me.
>>> 
>>> Justin
>> 
>> 


Mime
View raw message