flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject Re: [DISCUSS] Discuss Release Apache FlexJS 0.8.0 RC1
Date Mon, 12 Jun 2017 09:27:47 GMT
Actually not by removing the credentials … by using an empty settings.xml or none at all
and having a default. My settings-test.xml only contains the location of the maven local repo
and no other settings therefore Maven defaults to its built-in defaults (I did manually provide
the artifacts the mavenizer would have created though)


Am 12.06.17, 11:23 schrieb "Justin Mclean" <justin@classsoftware.com>:

    > mvn clean install -Drat.skip=true -s ~/.m2/settings-test.xml
    > (My settings-test.xml simply excludes the Apache snapshot repo)
    So by just removing this right?
    If so I’m still getting this:
    error: patch failed: js/target/downloads/svg.js:401
    error: js/target/downloads/svg.js: patch does not apply
    When compiling typedefs here:
    > Another thing I noticed, is that the build is producing SNAPSHOT versions and is
referencing SNAPSHOT versions. We will not be able to publish these artifacts to Maven Central.
Well we will also not be able to publish them to the Apache Repo for release.
    So it likely in your opinion we need to make changes and publish another RC or perhaps
even a 0.8.1?
    > bash-3.2$ git --version
    > git version 2.12.0
    I have  2.11.0 I’ll try 2.12.0 and see if that makes any difference.
    > But not being able to release stuff to Maven-Central is reason enough for a -1 …
sorry for that … 
    You'll need to do that in the [VOTE] thread for it to count.

View raw message