flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Dove <greg.d...@gmail.com>
Subject Re: [LAST CALL] Release FlexJS/FalconJX 0.8.0
Date Mon, 01 May 2017 16:11:20 GMT
Chris, or perhaps Alex:
With the latest changes for maven, I am trying to figure out how to get the
same result with maven as

which previously permitted js-only compilation so that COMPILE::JS was not
needed in js-only target project, and it was possible to use, for example,
var style:CSSStyleDeclaration,
window['Intl'] etc
outside of COMPILE::JS

Is this still possible in some way after the change? I can see options for
maven like
skipAS etc, but have not figured out a combination that achieves the same.

I am hoping there is something simple that I didn't see - I am still
getting my head around using maven, (apart from finding it mostly very
intuitive to 'read').
If not, I can always go through the code and wrap things in COMPILE::JS,
was just hoping that I don't need to do that.

On Tue, May 2, 2017 at 2:51 AM, Christofer Dutz <christofer.dutz@c-ware.de>

> But in general, “mvn clean compile” should have worked. I even double
> checked with the debugger … if the other modules are part of the build it
> would acutally resolve the artifacts from the target directories instead of
> from the maven local repo … I’ll continue investigating this.
> Chris
> Am 30.04.17, 23:42 schrieb "Justin Mclean" <justin@classsoftware.com>:
>     Hi,
>     > You are running “mvn clean compile” which compiles each module and
> created the swcs in the target directories. Unfortunately, they just stay
> there as they are not copied to your maven local repository.
>     Thanks Chris that would explain the error.
>     > To do that, you need to run “mvn clean install”. I would give that a
> try.
>     Looks like typedef is now broken as I’m getting this:
>     [INFO] --- exec-maven-plugin:1.5.0:exec (patch-js) @
> flexjs-typedefs-js ---
>     error: patch failed: js/target/downloads/svg.js:401
>     error: js/target/downloads/svg.js: patch does not apply
>     [ERROR] Command execution failed.
>     I’m assume the patch file no longer matches what’s at [1]?
>     Thanks,
>     Justin
>     1. https://storage.googleapis.com/google-code-archive-
> downloads/v2/code.google.com/closureidl/svg.js

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message