flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject Re: Problem with the Mavenizer and Air >= 24 on macs
Date Fri, 05 May 2017 15:02:52 GMT
Hi Alex,

Well I guess I could probably do that, but I am no fan of this. The Mavenizer is platform
independent and is generally able to provide the Mac SDK on a Windows machine. Also, there
are major drawbacks when starting OS processes from within a Java VM. That’s why my implementation
should be able to unpack the DMGs on any platform.

Chris



Am 05.05.17, 16:24 schrieb "Alex Harui" <aharui@adobe.com>:

    
    
    On 5/5/17, 12:10 AM, "Christofer Dutz" <christofer.dutz@c-ware.de> wrote:
    
    >Hi,
    >
    >I just noticed that I was unable to use the mavenizer (aka
    >flex-sdk-converter) for Air 24 and 25. A short investigation resulted in
    >the result that this is probably only a problem on macs as Adobe changed
    >the packaging of the AIR SDK starting with version 24 and right now we
    >don’t have any option to access DMGs with non-GPL libraries. I am working
    >on implementing this logic from scratch inside the Mavenizer, but I think
    >I still need a little time to finish this.
    
    OK, I guess.  Any reason you can't exec the same MacOS command line tools
    we use in the installer?  Or is that what you mean by implementing from
    scratch?
    
    Thanks,
    -Alex
    
    

Mime
View raw message