flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: 4.16.0 Install issues (was Re: [ANNOUNCE] Apache Flex 4.16.0 released)
Date Thu, 16 Mar 2017 21:12:22 GMT

On 3/16/17, 12:25 PM, "Nicholas Kwiatkowski"
<nicholaskwiatkowski@gmail.com> wrote:

>I think there is some reason to use very old versions of AIR ( < 4), but
>between AIR 4 and 23 it should be ok.   Do you know if it effects the old
>ones (which still support some older OSs)?

Probably.  The issue is the installer script tries to see AIR SDK is a
tbz2 or dmg file.  The Installer uses ant_on_air which uses Ant 1.7 logic
and it fails to detect tbz2 and always tries the dmg route.  That's why
actually using Ant 1.9 works.

So, AFAICT, the situation is that the Installer can install 4.16.0 with
FP/AIR 24 and newer, and 4.15.0 and earlier with FP/AIR 23 and older.
4.16.0 with FP/AIR 23 and older can be installed via Ant 1.9 or newer, and
4.15.0 with FP/AIR 24 and newer cannot be installed at all.  You can use
FP/AIR 23 and older then use one of the upgrade scripts.


View raw message