flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Dove <greg.d...@gmail.com>
Subject Re: [FlexJS] Any gude to getting checkintests working
Date Sat, 04 Mar 2017 18:45:05 GMT
Chris, I focused on getting ant checkintests to work first because I saw
more progress there (browser launch, but execution fail) initially. After
downgrading firefox it worked properly with the older selenium setup that
the ant build uses.

I then tried to get maven build working and finally realised that it was a
problem I had earlier with
set webdriver.gecko.driver=path_to/geckodriver.exe
In a windows .bat file

vs. -Dwebdriver.gecko.driver=path_to/geckodriver.exe

On the mvn command line

(I had this before with distributionTargetFolder
It only works with the command line define)

So, I think it probably would have worked like it should without the FF
broswer downgrade for maven, I just did not realise what I was doing wrong
for maven until after I had already addressed the issue for ant.

-Greg
[sent from my phone]

On 4/03/2017 10:08 PM, "Christofer Dutz" <christofer.dutz@c-ware.de> wrote:

Hi Greg,

Just because this thread had gotten a little confusing because of the mixup
of Ant and Maven related infos.
Did I understand, that you got the tests working on windows with Maven, but
had to downgrade your firefoxx?

I just checked:
We are using selenium-firefox-driver in version 3.0.1 in the Maven build.
I just checked my firefox and this is in Version 50.1.0 too … eventually I
should update to the latest version … oh … ok … it automatically updated ☹

The latest version of the selenium-firefox-driver is 3.2.0 … would be very
easy to update. Then we probably should get ASF Infra to update the
geckodriver on the Jenkins build agents (and eventually update Firefox).

 Chris


Am 04.03.17, 08:05 schrieb "Greg Dove" <greg.dove@gmail.com>:

    That was it. Downgrading firefox worked. Thanks!

    I saw the browser launch and quick test from ant  checkintests,

    I did not see it from the maven build:
    mvn clean install -P build-examples -Drat.skip=true

    ...then I remembered I had an unrelated issue with using
    distributionTargetFolder defined from a locally set environment variable
    (this is Windows, might be windows-specific) for maven

    so... for posterity, this is the maven version that works for me on
windows:

    mvn clean install -P build-examples -Drat.skip=true
    -Dwebdriver.gecko.driver=%cd%/../testing/selenium/firefox/
geckodriver.exe

    where 'testing' in

    testing/selenium/firefox/geckodriver.exe

    is a sibling folder to flex-asjs that I just set up arbitrarily in my
local
    flexjs related directories

    So I now (finally) have the browser tests working. :)





    On Sat, Mar 4, 2017 at 7:04 PM, Alex Harui <aharui@adobe.com> wrote:

    >
    >
    > On 3/3/17, 9:53 PM, "Greg Dove" <greg.dove@gmail.com> wrote:
    >
    > >Thanks, I'm running 51.0.1, I'll see if I can downgrade that.
Suffice to
    > >say that "If you are using Ant, it should just work" was not quite
    > >applicable in my case :).
    > >A lof of this is very likely due to me being unfamiliar with the
territory
    > >here, though.
    >
    > You're definitely right that it didn't just work.  Thanks for helping
see
    > where the problems might be.
    >
    > If you can't downgrade FF, it might be time to try upgrading
Selenium.  We
    > upgrade Selenium every so often.
    >
    > Thanks,
    > -Alex
    >
    >

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message