flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Dove <greg.d...@gmail.com>
Subject Re: Typedef issue causing flex-asjs to fail to compile
Date Wed, 22 Mar 2017 16:40:27 GMT
Alex, I pushed this change, using undefined as discussed in the ticket.
The standard compiler tests all pass, but there is, I think, an unrelated test
in flexjs.dependent.tests that is currently failing
in TestFlexJSMXMLApplication (I admit that I did not revert my change to
check it was occurring prior, but I can't see how it could be related)
It is a css in/css out comparison test.
As near as I can tell the failing css test had the correct css settings in
the output, but the order of them does not always match the expected output
(it does for the most part). So height:176px might appear before color:#ff
in expected result in some parts and occurs the other way around in the
corresponding part of the output, but the expected items are all there. I
did not dig into this, but I perhaps the ordering was changed or some new
functionality was added where perhaps ordering of output was not
guaranteed.




On Tue, Mar 21, 2017 at 3:56 AM, Alex Harui <aharui@adobe.com> wrote:

>
>
> On 3/20/17, 12:00 AM, "Greg Dove" <greg.dove@gmail.com> wrote:
>
> >I agree that 10 is wrong, but
> >reading both AS and JS doc, I'm now thinking that if the second argument
> >is missing that the compiler should use 0.
>
> +1.  Let's use 0.
>
> Thanks for doing such a through investigation.
> -Alex
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message