flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harbs <harbs.li...@gmail.com>
Subject Re: flex-typedefs build failing
Date Tue, 14 Mar 2017 21:07:01 GMT
I just had a problem with svg.js as well.

Deleting the file and running ant again on typedefs solved it for me.

Harbs

> On Mar 14, 2017, at 10:56 PM, Greg Dove <greg.dove@gmail.com> wrote:
> 
> I am seeing this also. It almost feels like it is applying the patch on
> download and then trying again (but I have really no idea)
> 
> 
> ant build works fine with some warnings about LoggerErrorManager println
> but I could not get regular maven build to work
> 
> 
> One way I could get the mvn build to work was this, which might provide
> some clues?:
> 
> mvn clean
> cd js
> ant download
> cd..
> cd google_maps
> ant download
> cd..
> mvn install
> 
> that was fun :)
> 
> 
> On Wed, Mar 15, 2017 at 6:51 AM, Alex Harui <aharui@adobe.com> wrote:
> 
>> Are you running "mvn clean install" or something else?  I don't remember
>> what part of the build brings down svg.js and patches it, but if you don't
>> bring down svg.js each time, the patch will not apply the second time.
>> 
>> HTH,
>> -Alex
>> 
>> On 3/14/17, 5:58 AM, "Justin Mclean" <justin@classsoftware.com> wrote:
>> 
>>> Hi,
>>> 
>>> Is it just me or is flex-typedefs currently broken? Looks like the patch
>>> file may need updating?
>>> 
>>> When trying to compile (on develop) I get this:
>>> [INFO] --- exec-maven-plugin:1.5.0:exec (patch-js) @ flexjs-typedefs-js
>>> ---
>>> error: patch failed: js/target/downloads/svg.js:401
>>> error: js/target/downloads/svg.js: patch does not apply
>>> [ERROR] Command execution failed.
>>> 
>>> Thanks,
>>> Justin
>> 
>> 


Mime
View raw message