flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Rovira <carlos.rov...@codeoscopic.com>
Subject Re: [FlexJS][NextGenAS][Maven] Setup VSCode NextGenAS to 0.3.0 to work with maven distribution
Date Tue, 24 Jan 2017 16:54:42 GMT
An IntelliJ too :)

We should encourage to go with VSCode - NextGenAS (since is open source) or
Moonshine (but I still didn't try it) in first term.
Then comercial IDEs in development (IntelliJ IDEA) or FDT (as well has pass
many time since the last time I try it, so don't know how works with
FlexJS), and Flash Builder should be left since is not updated in the last
6+ years, so for me is a deprecated legacy IDE.

Thanks Josh!


2017-01-24 17:20 GMT+01:00 Josh Tynjala <joshtynjala@gmail.com>:

> If we're not on par, I'd say we're very close. Someone should give the
> Maven distribution a try with Flash Builder. That's the strictest IDE, in
> terms of deciding if a Flex SDK is valid or not.
>
> - Josh
>
> On Tue, Jan 24, 2017 at 8:08 AM, Christofer Dutz <
> christofer.dutz@c-ware.de>
> wrote:
>
> > Does that mean, that we finally managed to get the Maven distribution on
> > par with the Ant one? … *PARTY* :-)
> >
> > Chris
> >
> > Am 24.01.17, 17:03 schrieb "Josh Tynjala" <joshtynjala@gmail.com>:
> >
> >     Hi Carlos,
> >
> >     I don't notice anything that seems missing in your instructions.
> > Basically,
> >     once you create a binary distribution with Maven, VSCode will now
> > treat it
> >     as a valid SDK, the same as if the distribution were built with Ant
> >     instead. No extra steps on the VSCode side.
> >
> >     - Josh
> >
> >     On Jan 24, 2017 4:58 AM, "Carlos Rovira" <carlosrovira@apache.org>
> > wrote:
> >
> >     Hi,
> >
> >     just see that NextGenAS 0.3.0 was available and updated in order to
> > set up
> >     with maven distribution.
> >
> >     This is most a step by step to see if I'm configuring it ok and to
> help
> >     others to get to it:
> >
> >     1.- First I create a maven flexjs sdk distribution with the
> instruction
> >     here:
> >     https://cwiki.apache.org/confluence/display/FLEX/
> > Building+FlexJS+with+Maven
> >     in flex-asjs I put:
> >
> >     mvn -s settings-template.xml
> >     -DdistributionTargetFolder={pathToDistributionDirectory} -P
> >     build-distribution clean install
> >
> >     for example, my {pathToDistributionDirectory} is my sdks folder:
> >     /Users/carlosrovira/Dev/Flex/sdks/
> >
> >     2.- As distribution is created, I go to
> >     distribution/target/apache-flex-flexjs-0.8.0-SNAPSHOT-bin.zip and
> > unzip it
> >     in the same folder.
> >
> >     3.- When open VSCode it warns me about to update settings to:
> >
> >     {
> >         "nextgenas.sdk.editor":
> >     "/Users/carlosrovira/Dev/Flex/sdks/distribution/target/
> >     apache-flex-flexjs-0.8.0-SNAPSHOT/"
> >     }
> >
> >     4.- Then I restart VSCode.
> >
> >     Is this guide ok? or I'm missing something?
> >
> >     Thanks!
> >
> >     --
> >     Carlos Rovira
> >     http://about.me/carlosrovira
> >
> >
> >
>



-- 

Carlos Rovira
Director General
M: +34 607 22 60 05
http://www.codeoscopic.com
http://www.avant2.es

Este mensaje se dirige exclusivamente a su destinatario y puede contener
información privilegiada o confidencial. Si ha recibido este mensaje por
error, le rogamos que nos lo comunique inmediatamente por esta misma vía y
proceda a su destrucción.

De la vigente Ley Orgánica de Protección de Datos (15/1999), le comunicamos
que sus datos forman parte de un fichero cuyo responsable es CODEOSCOPIC
S.A. La finalidad de dicho tratamiento es facilitar la prestación del
servicio o información solicitados, teniendo usted derecho de acceso,
rectificación, cancelación y oposición de sus datos dirigiéndose a nuestras
oficinas c/ Paseo de la Habana 9-11, 28036, Madrid con la documentación
necesaria.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message