flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Tynjala <joshtynj...@gmail.com>
Subject Re: [FlexJS] Switching SDK from 0.7 to 0.8(dev) and rebuild FlexJS project without cleaning will cause runtime error in js mode
Date Wed, 11 Jan 2017 15:35:38 GMT
Pan is taking about using a nightly rather than building from the
repository, I think.

I also encountered this issue. I talked to Alex about this because it
confused me too. I guess the compiler does not always replace SDK JS files
in bin when rebuilding a project since they're usually exactly the same.
When switching SDKs, you can end up with files from the old SDK mixed with
files from the new SDK, and the two aren't necessarily compatible. Alex
recommended cleaning after switching SDKs.

- Josh

On Jan 11, 2017 12:47 AM, "Harbs" <harbs.lists@gmail.com> wrote:

> Make sure falcon and typedefs are both updated.
>
> On Jan 11, 2017, at 10:45 AM, Pan Li <PanLi@Prominic.NET> wrote:
>
> >
> >
> > I had reported this issue earlier, when I reported it last time I thought
> > it was compiler bug.
> > It isn't really a bug but I think it is better to report anyway.
> >
> > To reproduce the problem:
> > 1 Take any project which can work in both 0.7 and 0.8
> > build it with 0.7
> > 2 Using 0.8(dev) to build and run it in js mode
> > there will be js runtime error:
> >
> > TypeError: views.MyInitialView.superClass_.get__MXMLDescriptor is
> undefined
> > [Learn More]  MyInitialView.js:651:15
> >       .MXMLDescriptor.get
> > file:///Users/lipan/Downloads/testbmmljan09/bin/js-debug/
> views/MyInitialView.js:651:15
> >       org.apache.flex.core.ContainerBase.prototype.addedToParent
> > file:///Users/lipan/Downloads/testbmmljan09/bin/js-debug/
> org/apache/flex/core/ContainerBase.js:173:5
> >       org.apache.flex.core.Application.prototype.addElement
> > file:///Users/lipan/Downloads/testbmmljan09/bin/js-debug/
> org/apache/flex/core/Application.js:115:3
> >       org.apache.flex.core.Application.prototype.initialize
> > file:///Users/lipan/Downloads/testbmmljan09/bin/js-debug/
> org/apache/flex/core/Application.js:265:3
> >       org.apache.flex.core.Application.prototype.start
> > file:///Users/lipan/Downloads/testbmmljan09/bin/js-debug/
> org/apache/flex/core/Application.js:236:5
> >       <anonymous>
> > file:///Users/lipan/Downloads/testbmmljan09/bin/js-debug/
> index.html:188:3
> >
> >
> > The fix is simple, if you clean the project before build again it will
> > work.
> >
> >
> >
> > My Apache Flex community contribution is working on the open source
> > Moonshine-IDE.com for FlexJS.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message