flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject Re: AW: [FlexJS] Problem with building Tour de FlexJS by Maven
Date Sun, 22 Jan 2017 19:31:45 GMT
Looking at the problem a little more in detail, I guess it might be related to the namespace
declaration in Express.
Here most classes are marked as: lookupOnly="true"
Other than Express only Flat seems to use this. 

I’ve been digging through the Libraries and catalog.xmls inside the SWCs.
I guess the problem is, that in the library HTML the needed classes are included in the library,
but not in listed in the components part and hereby not bound to a library namespace.

I have to admit I don’t really like the current state of both HTML and Basic binding to
the same namespace offering some identical classes but with different signatures. I think
we definitely need to clean this up to avoid problems in the near future. As soon as someone
depends on something that depends on Basis and another library that depends on HTML, things
could get ugly.

Could someone please take a look at the Namespaces, catalog.xmls and so on and help sort out
what’s the problem? I’ve tried out several things, but I can’t seem to manage to get
“Slider” into the HTML swcs catalog.xml :-(

Chris


Am 22.01.17, 15:18 schrieb "Christofer Dutz" <christofer.dutz@c-ware.de>:

    Ok,
    
    I checked out the project and added your pom. I could reproduce the problems. 
    I think they are related to the Express module. You are using the Namespace: library://ns.apache.org/flexjs/express
    When having a look at the namespaces for the Express module I could see that the namespace
for JS is full of classes, but for as ist’s empty.
    The pom would currently do a “swf” compilation so I guess it’s picking up the empty
namespace.
    
    I’ll look into this a little more later.
    
    Chris
    
    
    
    Am 22.01.17, 12:34 schrieb "piotrz" <piotrzarzycki21@gmail.com>:
    
        I failed like my build :/ Here is the actual pom [1][2]. It looks like I'm
        missing some dependencies but not sure which one.
        
        
        [1] https://paste.apache.org/KHvB
        [2] https://paste.apache.org/6lb7
        
        Piotr
        
        
        
        -----
        Apache Flex PMC
        piotrzarzycki21@gmail.com
        --
        View this message in context: http://apache-flex-development.2333347.n4.nabble.com/FlexJS-Problem-with-building-Tour-de-FlexJS-by-Maven-tp58527p58557.html
        Sent from the Apache Flex Development mailing list archive at Nabble.com.
        
    
    

Mime
View raw message