flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: [FlexJS] Updated Closure compiler from v20151015 to v20161201
Date Sat, 17 Dec 2016 22:21:31 GMT
It doesn't report errors, because I had to disable that because there we always closure errors
in normal execution :-(





Von meinem Samsung Galaxy Smartphone gesendet.


-------- Urspr√ľngliche Nachricht --------
Von: Alex Harui <aharui@adobe.com>
Datum: 17.12.16 21:08 (GMT+01:00)
An: joshtynjala@gmail.com, dev@flex.apache.org
Betreff: Re: [FlexJS] Updated Closure compiler from v20151015 to v20161201

For some reason the maven build did not report failure.  Errors were in the console log. 
I plan to look into that tonight.

The ci maven build is failing in the distribution step.  Hopefully Chris can help.

Sent from my LG G3, an AT&T 4G LTE smartphone

------ Original message------
From: Josh Tynjala
Date: Sat, Dec 17, 2016 8:15 AM
To: dev@flex.apache.org;
Subject:Re: [FlexJS] Updated Closure compiler from v20151015 to v20161201

Oh, right, I forgot that Maven doesn't use the compiler's config files, for
some reason. I wish it would so that we could keep the builds in sync
easier. Oh well. Thanks, Alex!

- Josh

On Dec 16, 2016 10:41 PM, "Alex Harui" <aharui@adobe.com> wrote:

> Thanks Josh!  I had to make one fix for Maven in flex-typedefs, but your
> changes build with Ant and Maven locally for me.
>
> -Alex
>
> On 12/16/16, 3:42 PM, "Josh Tynjala" <joshtynjala@gmail.com> wrote:
>
> >Hey folks,
> >
> >I updated flex-falcon to use a newer build of Closure compiler,
> >specifically v20161201. This also required an update of the Guava
> >dependency from v17.0 to v20.0. I have made the required changes to the
> >dependencies for both Ant and Maven builds.
> >
> >An update to Closure compiler means that we have the latest features and
> >bug fixes from Google for optimizing our JS release builds. For instance,
> >one new feature that prompted my desire to update should allow us to
> >improve JS source maps for release builds (to step through the original
> >ActionScript instead of the generated js-debug JavaScript). It also means
> >updated externs with the newest JavaScript browser APIs becoming exposed
> >to
> >ActionScript. Finally, the v20151015 build is getting to be over a year
> >old
> >now, and the longer we wait to update, the harder it will become!
> >
> >This change also affected the flex-typedefs and flex-asjs repositories a
> >bit. I had to make a few tweaks here and there because Closure compiler or
> >the externs became a little more strict, and some APIs were renamed. I
> >think I got everything running properly because the DataBindingExample
> >works correctly, but I encourage you to test more examples to be sure that
> >I didn't miss anything.
> >
> >If you're using the Ant build, you need to be sure to wipe before building
> >each of the repositories after you pull the latest changes. Be sure to
> >pull
> >from all three repos! This will ensure that the new dependencies are
> >downloaded to replace the old ones, and everything will be in sync.
> >
> >flex-falcon:
> >ant wipe-all
> >
> >flex-typedefs:
> >ant wipe
> >
> >flex-asjs:
> >ant super-clean
> >
> >I ran all of these on the Ant CI server, and I'll make tweaks as needed if
> >anything appears to break.
> >
> >- Josh
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message