flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Tynjala <joshtynj...@gmail.com>
Subject [FlexJS] Update Closure compiler?
Date Tue, 13 Dec 2016 23:34:35 GMT
Hey all,

I notice that the default Closure compiler version is 20151015. Can we
update to a newer build? I think their externs have been updated, and it's
good to be more up-to-date with those. I also discovered an interesting
change related to how Closure compiler generates source maps. Right now,
Closure compiler generates a source map for a FalconJX release build, but
it only maps to the JavaScript from the debug build. It doesn't read in the
source map that FalconJX generate from ActionScript for the debug build. It
appears that a more recent build of Closure compiler will read in existing
source maps and use them to generate the final source maps. If we update, a
release build from FalconJX should map all the way back to the original
ActionScript instead.

- Josh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message