flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [LAST CALL] Flex SDK 4.16
Date Mon, 21 Nov 2016 19:43:47 GMT

On 11/21/16, 6:16 AM, "omuppi1@gmail.com on behalf of OmPrakash Muppirala"
<omuppi1@gmail.com on behalf of bigosmallm@gmail.com> wrote:
>>>1.  In sdk-installer-config-4.0.xml, for the new SDK entries, I don't
>> >where to get the cacheID and cacheID2 properties.
>> MD5Checker will compute the values.
>Where is the code for that?

In flex-utilities

>> >2.  I have tested the installer.xml changes on Ant.  They work well for
>> >both tbz2 and dmg files.  But I have not been able to test it out with
>> >Apache Flex Installer.  I couldn't figure out how to test the modified
>> >installer.xml without making an actual release of the flex-sdk
>> Pretty sure there is a command-line option to point to a local xml file.
>> The Ant build for the Installer has some targets to point to a local xml
>> file.
>I tried that.   But this setting seems to confuse the Installer and causes
>it to look for the SDK files from where the Installer.xml is specified.
>Maybe I am doing this wrong.  Can you test it out and see if this feature
>is working as intended?

I'm not sure what you are asking me to do.

I was able to run the installer on my Mac with a modified
sdk-installer-config-4.0.xml via:

 Apache\ Flex/Apache\ Flex\ SDK\ Installer.app/Contents/MacOS/Apache\
Flex\ SDK\ Installer

I had previously built the release packages with your installer.xml and
added to my local copy of sdk-installer-config-4.0.xml the following entry
underneath the Nightly:

   <Local id="Nightly" version="LOCAL"
file="apache-flex-sdk-4.16.0-bin" dev="true" nocache="true"/>

Then in the Installer I right-click, choose "Show Dev Builds" and select
Flex SDK LOCAL".  I found that after approving the licenses but before
hitting the "install" button that I had to  manually copy the
sdk-installer-config-4.0.xml into destination folder.

Then things started to install but there was an error 3003 in
unzipOrMountDMG.  Not sure what that is, but I took a quick look at the
installer.xml and I'm not sure the <condition> is doing the right thing.
I don't think you are supposed to have an "else" clause when a property is
used in "if"/"unless".

Anyway, you should be able to debug this way.

FWIW, if you need to actually debug the installer, then I use the various
Ant targets to build the installer and run it.
I first just run Ant with -Dno.cleanup
Then I run Ant with the "debug" target and -DLOCAL_CONFIG_URL=<path to
local sdk-installer-config.xml.


View raw message