flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [DISCUSS] Discuss Release Apache FlexJS 0.7.0 RC1
Date Fri, 09 Sep 2016 17:46:17 GMT
Hi Josh,

I updated SVN and unzipped the binary, and compared it.  More seems to
have changed than I think should have.  Pom.xml files are referencing
0.8.0-SNAPSHOT, for example.  Maybe the ant steps I gave injected newer
stuff, not sure.  Can you verify what I'm seeing in case I did something
wrong?

Thanks,
-Alex

On 9/9/16, 10:05 AM, "Josh Tynjala" <joshtynjala@gmail.com> wrote:

>Okay, I'll leave installer.xml as-is. I just committed the new binaries
>with the missing file restored to the dist SVN.
>
>- Josh
>
>On Fri, Sep 9, 2016 at 9:59 AM, Alex Harui <aharui@adobe.com> wrote:
>
>>
>>
>> On 9/9/16, 9:51 AM, "Josh Tynjala" <joshtynjala@gmail.com> wrote:
>>
>> >Okay, I think I have everything set up properly, and I'm ready to
>>commit
>> >the updated binaries to SVN. However, as a final test just to be sure,
>>I
>> >tried to extract the new binary and manually run ant -f installer.xml.
>> >Unfortunately, it failed. I noticed that installer.xml still references
>> >0.6.0, so it was trying to download the wrong files:
>> >
>> ><property name="flexjs.version" value="0.6.0"/>
>> ><property name="falcon.version" value="0.6.0"/>
>>
>> Yes, we didn't catch that during the vote and that was fouling up the
>> Installer as well.  I found a workaround for the Installer, but not Ant.
>>
>> >
>> >If I manually change them to 0.7.0, the installation script finishes
>> >successfully. Should I update those values too, before I upload?
>>
>> Technically, no, because then that modified source file isn't in an
>> approved source package, but IMO, it wouldn't be the end of the world if
>> you did.  I don't know how many folks install using Ant, but I think it
>>is
>> very few, and those Ant users should be able to get past this by using:
>>
>> ant -f installer.xml -Dflexjs.version=0.7.0 -Dfalcon.version=0.7.0
>>
>>
>> So if I were doing it, I wouldn't change installer.xml, but you are
>>doing
>> the work so it is up to you.
>>
>> Thanks,
>> -Alex
>>
>>

Mime
View raw message