flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Dove <greg.d...@gmail.com>
Subject Re: git commit: [flex-asjs] [refs/heads/develop] - js-config-template (plus jquery and node): added missing reference to Core.swc, which is required for org.apache.flex.utils.Language
Date Fri, 15 Jul 2016 06:30:37 GMT
I encountered this today when I tried to build flexjs for the first time
with the latest develop code.

It's probably bad style (I am still figuring this stuff out, however
duplicating the same library element at the lower level does seem "wrong"),
but one option could be to do this [1] - that makes the ant build work
again, at least.


1. https://dl.dropboxusercontent.com/u/13816570/config-js-config_patch.patch



On Fri, Jul 15, 2016 at 4:56 PM, Alex Harui <aharui@adobe.com> wrote:

>
>
> On 7/14/16, 2:22 PM, "Josh Tynjala" <joshtynjala@gmail.com> wrote:
>
> >So js-config.xml needs to be updated to include Core.swc in the
> >library-path so that the org.apache.flex.utils.Language class is
> >available.
> >However, it looks like the build process for Core.swc may actually be
> >referencing js-config.xml, so it ends up expecting itself as a
> >dependency... Any ideas on how to fix that?
>
> Well, we should probably break Language out of Core, but I think you may
> still have an issue building the SWC with just Language in it.  You may
> need another config like js-only-config that is only used to get the chain
> of SWCs started.
>
> -Alex
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message