flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Dove <greg.d...@gmail.com>
Subject Re: AW: [FLEXJS, TYPEDEFS]
Date Tue, 26 Jul 2016 23:22:35 GMT
I just finally got around to trying this as well and encountered the same
issue, and yes, I have used ant previously as well, otherwise it is looking
very good - I especially like the sound of the distributionTargetFolder
option :)

The rat report shows the following for me:

3 Unknown Licenses

*****************************************************

Files with unapproved licenses:

  D:/FLEXSDKS/dev/flex-falcon/compiler/lib/external/antlr-LICENSE.html
  D:/FLEXSDKS/dev/flex-falcon/compiler/lib/external/jflex-COPYRIGHT
  D:/FLEXSDKS/dev/flex-falcon/compiler/lib/external/lzma-sdk-LICENSE.html

... (I assume the rest is ok)

On Wed, Jul 27, 2016 at 7:52 AM, Christofer Dutz <christofer.dutz@c-ware.de>
wrote:

> I guess if you had run the Ant build before, there might be some files
> generated in places I didn't anticipate. So the RAT plugin is complaining
> about these files not having Apache Headers in them ... usually the
> target/rat.txt file will contain a list of the violating files.
>
>
> Chris
>
> ________________________________
> Von: Peter Ent <pent@adobe.com>
> Gesendet: Dienstag, 26. Juli 2016 17:40:58
> An: dev@flex.apache.org
> Betreff: Re: AW: [FLEXJS, TYPEDEFS]
>
> Hi,
>
> I just finished installing and running maven. I was able to build
> flex-falcon "utils" but when I went to build the compiler, it failed on
> the rat report check (below). But I think it would have worked nicely
> otherwise. Great job!
>
> [INFO] Rat check: Summary over all files. Unapproved: 18, unknown: 18,
> generated: 0, approved: 2005 licenses.
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Apache Flex - FlexJS: Compiler: Parent ............. SUCCESS [
> 2.541 s]
> [INFO] Apache Flex - FlexJS: Compiler: Test Utils ......... SUCCESS [
> 1.554 s]
> [INFO] Apache Flex - FlexJS: Compiler: Compiler ........... FAILURE [
> 26.918 s]
> [INFO] Apache Flex - FlexJS: Compiler: Compiler-JX ........ SKIPPED
> [INFO] Apache Flex - FlexJS: Compiler: Debugger ........... SKIPPED
> [INFO] Apache Flex - FlexJS: Compiler: OEM Layer .......... SKIPPED
> [INFO] Apache Flex - FlexJS: FlexJS Ant Tasks ............. SKIPPED
> [INFO] Apache Flex - FlexJS: FlexJS Maven Plugin .......... SKIPPED
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 31.259 s
> [INFO] Finished at: 2016-07-26T11:35:14-04:00
> [INFO] Final Memory: 52M/1114M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.rat:apache-rat-plugin:0.12:check
> (license-check) on project compiler: Too many files with unapproved
> license: 18 See RAT report in:
> /Users/pent/dev/flex-falcon/compiler/target/rat.txt -> [Help 1]
>
>
>
> On 7/26/16, 2:19 AM, "Christofer Dutz" <christofer.dutz@c-ware.de> wrote:
>
> >By the way ... did you give the Maven build a try?
> >
> >
> >Chris
> >
> >________________________________
> >Von: Peter Ent <pent@adobe.com>
> >Gesendet: Montag, 25. Juli 2016 20:05:49
> >An: Alex Harui; dev@flex.apache.org
> >Betreff: Re: [FLEXJS, TYPEDEFS]
> >
> >Got this to work with help from Alex. I had FALCONJX_HOME pointing to an
> >old directory: flex-falcon/compiler.jx; it should have been pointing to
> >flex-falcon/compiler-jx
> >
> >—peter
> >
> >From: Alex Harui <aharui@adobe.com<mailto:aharui@adobe.com>>
> >Date: Monday, July 25, 2016 at 11:42 AM
> >To: Peter Ent <pent@adobe.com<mailto:pent@adobe.com>>,
> >"dev@flex.apache.org<mailto:dev@flex.apache.org>"
> ><dev@flex.apache.org<mailto:dev@flex.apache.org>>
> >Subject: Re: [FLEXJS, TYPEDEFS]
> >
> >Try ant all in falcon again.
> >
> >Sent from my LG G3, an AT&T 4G LTE smartphone
> >
> >------ Original message------
> >From: Peter Ent
> >Date: Mon, Jul 25, 2016 7:56 AM
> >To: dev@flex.apache.org<mailto:dev@flex.apache.org>;
> >Subject:Re: [FLEXJS, TYPEDEFS]
> >
> >Running ant in flex-typedefs/jquery does not give the error and builds
> >successfully. I do not have FLEX_FALCON environment var set at all.
> >—peter
> >
> >On 7/25/16, 10:51 AM, "Alex Harui"
> ><aharui@adobe.com<mailto:aharui@adobe.com>> wrote:
> >
> >>Go to flex-typedefs/jquery and run 'ant'.  Do you get the same errors?
> >>If
> >>so, do you have a FLEX_FALCON environment variable pointing somewhere
> >>other than flex-falcon?
> >>
> >>-Alex
> >>
> >>On 7/25/16, 7:34 AM, "Peter Ent" <pent@adobe.com<mailto:pent@adobe.com>>
> >>wrote:
> >>
> >>>Yes, I had done that as well. So this time I did:
> >>>
> >>>typedefs:  ant wipe
> >>>falcon:    ant wipe-all; ant all
> >>>
> >>>Get same errors below.
> >>>
> >>>On 7/25/16, 10:27 AM, "Alex Harui"
> >>><aharui@adobe.com<mailto:aharui@adobe.com>> wrote:
> >>>
> >>>>Did you also do a "wipe" in flex-typedefs?  IIRC, that was the repo
> >>>>that
> >>>>was on the wrong branch and could have left cruft.
> >>>>
> >>>>-Alex
> >>>>
> >>>>On 7/25/16, 7:23 AM, "Peter Ent"
> >>>><pent@adobe.com<mailto:pent@adobe.com>> wrote:
> >>>>
> >>>>>So back to this.
> >>>>>
> >>>>>This morning I did a new pull from flex-falcon/typedefs/asjs just
to
> >>>>>be
> >>>>>certain, I think a couple of new things came down.
> >>>>>
> >>>>>I did ant wipe-all in falcon followed by ant all. I get this error
at
> >>>>>the
> >>>>>end of the build (below). Is falcon supposed to be built first? I'm
> >>>>>assuming typedefs needs the compiler since I saw it using compc (at
> >>>>>least). And why is the flex-falcon build getting stuff for
> >>>>>flex-typedefs
> >>>>>(see download: part of the console log, below)? This is why I'm
> >>>>>wondering
> >>>>>if flex-typedefs get built first - shouldn't it be getting the stuff
> >>>>>in
> >>>>>its own directories?
> >>>>>
> >>>>>‹peter
> >>>>>
> >>>>>download:
> >>>>>      [get] Getting:
> >>>>>
> https://raw.githubusercontent.com/google/closure-compiler/master/contr
> >>>>>i
> >>>>>b
> >>>>>/
> >>>>>e
> >>>>>x
> >>>>>terns/jquery-1.9.js
> >>>>>      [get] To:
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/downloads/jquery-1.9.js
> >>>>>
> >>>>>
> >>>>>preprocess:
> >>>>>
> >>>>>
> >>>>>externc:
> >>>>>     [java] event parameters not found!  0
> >>>>>     [java] fx parameters not found!  0
> >>>>>     [java] 0.950329 seconds
> >>>>>     [java] Java Result: 255
> >>>>>
> >>>>>
> >>>>>postprocess:
> >>>>>
> >>>>>
> >>>>>compc:
> >>>>>     [java] Loading configuration:
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/compile-as-config.xml
> >>>>>     [java]
> >>>>>     [java]
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/externc/
> >>>>>c
> >>>>>o
> >>>>>n
> >>>>>s
> >>>>>t
> >>>>>ants/$.as:3
> >>>>>     [java] Warning: Incompatible initializer value of type 'int'
> >>>>>where
> >>>>>'jQuery' is expected. An initial value of null will be used instead.
> >>>>>     [java]     public const $:jQuery = undefined;
> >>>>>     [java]                             ^
> >>>>>     [java]
> >>>>>     [java]
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/externc/
> >>>>>i
> >>>>>n
> >>>>>t
> >>>>>e
> >>>>>r
> >>>>>faces/jQueryAjaxSettingsExtra.as:20
> >>>>>     [java] Error: A conflict exists with definition processData
in
> >>>>>namespace public.
> >>>>>     [java]     function get processData():Boolean;
> >>>>>     [java]     ^
> >>>>>     [java]
> >>>>>     [java]
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/externc/
> >>>>>i
> >>>>>n
> >>>>>t
> >>>>>e
> >>>>>r
> >>>>>faces/jQueryAjaxSettingsExtra.as:20
> >>>>>     [java] Error: Cannot override an interface method.  Method
> >>>>>processData conflicts with a method in base interface
> >>>>>jQueryAjaxSettings.
> >>>>>     [java]     function get processData():Boolean;
> >>>>>     [java]     ^
> >>>>>     [java]
> >>>>>     [java]
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/externc/
> >>>>>i
> >>>>>n
> >>>>>t
> >>>>>e
> >>>>>r
> >>>>>faces/jQueryAjaxSettingsExtra.as:20
> >>>>>     [java] Error: Cannot override an interface method.  Method
> >>>>>processData conflicts with a method in base interface
> >>>>>jQueryAjaxSettings.
> >>>>>     [java]     function get processData():Boolean;
> >>>>>     [java]     ^
> >>>>>     [java]
> >>>>>     [java]
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/externc/
> >>>>>i
> >>>>>n
> >>>>>t
> >>>>>e
> >>>>>r
> >>>>>faces/jQueryAjaxSettingsExtra.as:21
> >>>>>     [java] Error: A conflict exists with definition processData
in
> >>>>>namespace public.
> >>>>>     [java]     function set processData(value:Boolean):void;
> >>>>>     [java]     ^
> >>>>>     [java]
> >>>>>     [java]
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/externc/
> >>>>>i
> >>>>>n
> >>>>>t
> >>>>>e
> >>>>>r
> >>>>>faces/jQueryAjaxSettingsExtra.as:21
> >>>>>     [java] Error: Cannot override an interface method.  Method
> >>>>>processData conflicts with a method in base interface
> >>>>>jQueryAjaxSettings.
> >>>>>     [java]     function set processData(value:Boolean):void;
> >>>>>     [java]     ^
> >>>>>     [java]
> >>>>>     [java]
> >>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/externc/
> >>>>>i
> >>>>>n
> >>>>>t
> >>>>>e
> >>>>>r
> >>>>>faces/jQueryAjaxSettingsExtra.as:21
> >>>>>     [java] Error: Cannot override an interface method.  Method
> >>>>>processData conflicts with a method in base interface
> >>>>>jQueryAjaxSettings.
> >>>>>     [java]     function set processData(value:Boolean):void;
> >>>>>     [java]     ^
> >>>>>     [java]
> >>>>>
> >>>>>
> >>>>>BUILD FAILED
> >>>>>/Users/pent/dev/flex-falcon/build.xml:140: The following error
> >>>>>occurred
> >>>>>while executing this line:
> >>>>>/Users/pent/dev/flex-typedefs/build.xml:57: The following error
> >>>>>occurred
> >>>>>while executing this line:
> >>>>>/Users/pent/dev/flex-typedefs/jquery/build.xml:140: Java returned:
2
> >>>>>
> >>>>>
> >>>>>
> >>>>>On 7/22/16, 11:20 PM, "Alex Harui"
> >>>>><aharui@adobe.com<mailto:aharui@adobe.com>> wrote:
> >>>>>
> >>>>>>I just did ant wipe-all and ant all in Falcon and it worked for
me.
> >>>>>>
> >>>>>>Did you run 'ant wipe' in flex-typedefs after switching to the
> >>>>>>develop
> >>>>>>branch?  Since that was the repo that was on the wrong branch
it
> >>>>>>might
> >>>>>>have some cruft in it that is messing up the flex-falcon build.
> >>>>>>
> >>>>>>-Alex
> >>>>>>
> >>>>>>On 7/22/16, 1:33 PM, "Peter Ent"
> >>>>>><pent@adobe.com<mailto:pent@adobe.com>> wrote:
> >>>>>>
> >>>>>>>No joy. I did switch to develop branch of flex-typedefs.
> >>>>>>>
> >>>>>>>I sync'd with Falcon and did an ant all; that failed so I
did a ant
> >>>>>>>wipe-all and then ant all. That fails:
> >>>>>>>
> >>>>>>>download:
> >>>>>>>      [get] Getting:
> >>>>>>>
> https://raw.githubusercontent.com/google/closure-compiler/master/con
> >>>>>>>t
> >>>>>>>r
> >>>>>>>i
> >>>>>>>b
> >>>>>>>/
> >>>>>>>e
> >>>>>>>x
> >>>>>>>terns/jquery-1.9.js
> >>>>>>>      [get] To:
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/downloads/jquery-1.9.js
> >>>>>>>
> >>>>>>>
> >>>>>>>preprocess:
> >>>>>>>
> >>>>>>>
> >>>>>>>externc:
> >>>>>>>     [java] event parameters not found!  0
> >>>>>>>     [java] fx parameters not found!  0
> >>>>>>>     [java] 0.902557 seconds
> >>>>>>>     [java] Java Result: 255
> >>>>>>>
> >>>>>>>
> >>>>>>>postprocess:
> >>>>>>>
> >>>>>>>
> >>>>>>>compc:
> >>>>>>>     [java] Loading configuration:
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/compile-as-config.xml
> >>>>>>>     [java]
> >>>>>>>     [java]
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/extern
> >>>>>>>c
> >>>>>>>/
> >>>>>>>c
> >>>>>>>o
> >>>>>>>n
> >>>>>>>s
> >>>>>>>t
> >>>>>>>ants/$.as:3
> >>>>>>>     [java] Warning: Incompatible initializer value of type
'int'
> >>>>>>>where
> >>>>>>>'jQuery' is expected. An initial value of null will be used
instead.
> >>>>>>>     [java]     public const $:jQuery = undefined;
> >>>>>>>     [java]                             ^
> >>>>>>>     [java]
> >>>>>>>     [java]
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/extern
> >>>>>>>c
> >>>>>>>/
> >>>>>>>i
> >>>>>>>n
> >>>>>>>t
> >>>>>>>e
> >>>>>>>r
> >>>>>>>faces/jQueryAjaxSettingsExtra.as:20
> >>>>>>>     [java] Error: A conflict exists with definition processData
in
> >>>>>>>namespace public.
> >>>>>>>     [java]     function get processData():Boolean;
> >>>>>>>     [java]     ^
> >>>>>>>     [java]
> >>>>>>>     [java]
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/extern
> >>>>>>>c
> >>>>>>>/
> >>>>>>>i
> >>>>>>>n
> >>>>>>>t
> >>>>>>>e
> >>>>>>>r
> >>>>>>>faces/jQueryAjaxSettingsExtra.as:20
> >>>>>>>     [java] Error: Cannot override an interface method. 
Method
> >>>>>>>processData conflicts with a method in base interface
> >>>>>>>jQueryAjaxSettings.
> >>>>>>>     [java]     function get processData():Boolean;
> >>>>>>>     [java]     ^
> >>>>>>>     [java]
> >>>>>>>     [java]
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/extern
> >>>>>>>c
> >>>>>>>/
> >>>>>>>i
> >>>>>>>n
> >>>>>>>t
> >>>>>>>e
> >>>>>>>r
> >>>>>>>faces/jQueryAjaxSettingsExtra.as:20
> >>>>>>>     [java] Error: Cannot override an interface method. 
Method
> >>>>>>>processData conflicts with a method in base interface
> >>>>>>>jQueryAjaxSettings.
> >>>>>>>     [java]     function get processData():Boolean;
> >>>>>>>     [java]     ^
> >>>>>>>     [java]
> >>>>>>>     [java]
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/extern
> >>>>>>>c
> >>>>>>>/
> >>>>>>>i
> >>>>>>>n
> >>>>>>>t
> >>>>>>>e
> >>>>>>>r
> >>>>>>>faces/jQueryAjaxSettingsExtra.as:21
> >>>>>>>     [java] Error: A conflict exists with definition processData
in
> >>>>>>>namespace public.
> >>>>>>>     [java]     function set processData(value:Boolean):void;
> >>>>>>>     [java]     ^
> >>>>>>>     [java]
> >>>>>>>     [java]
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/extern
> >>>>>>>c
> >>>>>>>/
> >>>>>>>i
> >>>>>>>n
> >>>>>>>t
> >>>>>>>e
> >>>>>>>r
> >>>>>>>faces/jQueryAjaxSettingsExtra.as:21
> >>>>>>>     [java] Error: Cannot override an interface method. 
Method
> >>>>>>>processData conflicts with a method in base interface
> >>>>>>>jQueryAjaxSettings.
> >>>>>>>     [java]     function set processData(value:Boolean):void;
> >>>>>>>     [java]     ^
> >>>>>>>     [java]
> >>>>>>>     [java]
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/target/generated-sources/extern
> >>>>>>>c
> >>>>>>>/
> >>>>>>>i
> >>>>>>>n
> >>>>>>>t
> >>>>>>>e
> >>>>>>>r
> >>>>>>>faces/jQueryAjaxSettingsExtra.as:21
> >>>>>>>     [java] Error: Cannot override an interface method. 
Method
> >>>>>>>processData conflicts with a method in base interface
> >>>>>>>jQueryAjaxSettings.
> >>>>>>>     [java]     function set processData(value:Boolean):void;
> >>>>>>>     [java]     ^
> >>>>>>>     [java]
> >>>>>>>
> >>>>>>>
> >>>>>>>BUILD FAILED
> >>>>>>>/Users/pent/dev/flex-falcon/build.xml:140: The following
error
> >>>>>>>occurred
> >>>>>>>while executing this line:
> >>>>>>>/Users/pent/dev/flex-typedefs/build.xml:57: The following
error
> >>>>>>>occurred
> >>>>>>>while executing this line:
> >>>>>>>/Users/pent/dev/flex-typedefs/jquery/build.xml:140: Java
returned: 2
> >>>>>>>
> >>>>>>>
> >>>>>>>Total time: 1 minute 47 seconds
> >>>>>>>pent-osx:flex-falcon pent$
> >>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>>On 7/22/16, 3:44 PM, "Alex Harui"
> >>>>>>><aharui@adobe.com<mailto:aharui@adobe.com>> wrote:
> >>>>>>>
> >>>>>>>>Did you switch to the develop branch in flex-typedefs?
 If you used
> >>>>>>>>the
> >>>>>>>>standard folder naming and structure, the scripts should
find it.
> >>>>>>>>You
> >>>>>>>>may
> >>>>>>>>need to sync and build flex-falcon first.
> >>>>>>>>
> >>>>>>>>-Alex
> >>>>>>>>
> >>>>>>>>On 7/22/16, 12:13 PM, "Peter Ent"
> >>>>>>>><pent@adobe.com<mailto:pent@adobe.com>> wrote:
> >>>>>>>>
> >>>>>>>>>Just sync'd flex-asjs repo. Must have missed the
email about it
> >>>>>>>>>now
> >>>>>>>>>requiring flex-typedefs. Cloned that and tried to
build it using
> >>>>>>>>>ant:
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>/Users/pent/dev/flex-typedefs/build.xml:52: The following
error
> >>>>>>>>>occurred
> >>>>>>>>>while executing this line:
> >>>>>>>>>
> >>>>>>>>>/Users/pent/dev/flex-typedefs/js/build.xml:29: src
> >>>>>>>>>'/Users/pent/dev/compiler-jx/lib/google/closure-compiler/compiler.
> >>>>>>>>>j
> >>>>>>>>>a
> >>>>>>>>>r
> >>>>>>>>>'
> >>>>>>>>>doesn't exist.
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>I don't see any README or instructions in the flex-typedefs
repo.
> >>>>>>>>>What
> >>>>>>>>>ENV vars are required to build it? I did a quick
search through
> >>>>>>>>>past
> >>>>>>>>>emails and while I found a number of git-related
items and some
> >>>>>>>>>discussion about it, I didn't see anything that provided
some
> >>>>>>>>>insight.
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>Thanks,
> >>>>>>>>>
> >>>>>>>>>Peter
> >>>>>>>>
> >>>>>>>
> >>>>>>
> >>>>>
> >>>>
> >>>
> >>
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message