flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harbs <harbs.li...@gmail.com>
Subject Re: Flash Builder borked
Date Wed, 13 Jul 2016 21:21:46 GMT
I’m not sure.

At some point (I think this morning — but it might have been yesterday) my Workspace became
completely corrupted and FB would not launch. I created a new workspace. I think it worked
at first, but I might be mistaken. I’m pretty sure I followed the instructions in the wiki
to set up FB correctly for developing the SDK.


On Jul 14, 2016, at 12:16 AM, Alex Harui <aharui@adobe.com> wrote:

> 
> 
> On 7/13/16, 1:50 PM, "Harbs" <harbs.lists@gmail.com> wrote:
> 
>> Flash Builder 4.7 has been pretty unstable for me.
>> 
>> I tried updating Java today hoping that it might help and everything went
>> haywire. I can not get FB to build anything now. I think installing Java
>> reset my default Java to 1.7, but I changed my symbolic link to point
>> back to 1.6. Nothing seems to help and I keep getting the following error:
>> 
>> java.lang.ClassCastException:
>> org.apache.flex.compiler.parsing.IASToken$ASTokenKind cannot be cast to
>> java.lang.String
> 
> Can you back out recent changes?  This is an error in the Falcon/FB
> integration.  I would need a reproducible test case in order to figure it
> out, but it probably means that a kind of compiler error is being reported
> that the integration code doesn't handle.  You can try adding more debug
> output to Application.java (in flex-compiler-oem) and see if you can
> figure out exactly what code causes this.
> 
> HTH,
> -Alex
> 


Mime
View raw message