flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: AW: AW: AW: [FalconJX] Extern builds use patch files instead of replace tasks
Date Tue, 31 May 2016 09:41:02 GMT
Hi Alex,

I am using a Mac and I tried what you suggested. Nothing worked :-(

So I had a look at the patch files and noticed that they seem to create and delete most of
the files. So I manually created a patch using:

diff -ur ../target/downloads/TweenJS-0.6.2/src/ TweenJS-0.6.2/src/ > tweenjs2.patch

And the patch created this way looked completely different. I was able to apply the patch
created this way without any problems. So maybe using git to create the patch isn't ideal.
I added my versions as tweenjs2.patch and easeljs2.patch and updated the maven build to use
these ... could you please try and update your workflow to generate the patch files differently.


Von: Alex Harui <aharui@adobe.com>
Gesendet: Freitag, 27. Mai 2016 18:08:30
An: Christofer Dutz; dev@flex.apache.org
Betreff: Re: AW: AW: AW: [FalconJX] Extern builds use patch files instead of replace tasks

Are you on a Mac or Windows machine?

I removed the ignore whitespace option from the ant build and the same 4 files failed so I
still suspect a line ending problem.  I noticed the whitespace option in the plugin defaults
to true so not sure why it doesn't work for you.

Can you try applying the patch manually and running unix2dos and or dos2unix on the 4 files
and the patch files?  That may not be a final solution but will prove it is a line ending

I also used a byte viewer to see that the patch and source had different line ending.

Sent from my LG G3, an AT&T 4G LTE smartphone

------ Original message------
From: Christofer Dutz
Date: Fri, May 27, 2016 1:35 AM
To: dev@flex.apache.org;
Subject:AW: AW: AW: [FalconJX] Extern builds use patch files instead of replace tasks

Hi Alex,

well I think I was blind and overlooked the "strip" option cause almost every Maven plugin
has a "skip" option and this one doesn't ... but using strip=7 I was able to apply the patches,
but still the 4 files still don't work correctly ... even with "ignoreWhitespace" option turned


Von: Alex Harui <aharui@adobe.com>
Gesendet: Donnerstag, 26. Mai 2016 18:50:59
An: dev@flex.apache.org
Betreff: Re: AW: AW: [FalconJX] Extern builds use patch files instead of replace tasks

On 5/26/16, 9:15 AM, "Christofer Dutz" <christofer.dutz@c-ware.de> wrote:

>Hi Alex,
>I had a look and the plugin doesn't offer this ... the paths seem to be
>invalid ones anyway ... it seems that you copied the originals to a
>directory "a" and the patched ones to one called "b" and created the
>patch from that. After fixing this path-problem, I was able to apply most
>of the patch. The only files that weren't able to be patched were:
>- createjs/events/EventDispatcher.js
>- easeljs/display/Container.js
>- easeljs/display/DisplayObject.js
>- easeljs/utils/SpriteSheetUtils.js
>When applying this manually IntelliJ complained about part of the patch
>already being applied. Any ideas?

I am using git to create and apply patches.  They seem to start paths with
"a" and "b".  Not sure why.  Every patch/diff I've worked with seems to
have that.

I found this page:

It lists a "skip" option which I think matches the -p option that should
cut directories of the paths.

It also lists an "ignore-whitespace" option which the Ant build is using
because EventDispatcher.js has different line endings (CRLF) than the
other files.  The other 3 files you mentioned may have the same issue.

Is it possible for you to use those two options?


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message