flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [FALCONJX] Jdk 1.6 incompatability in debugger module
Date Wed, 27 Apr 2016 13:08:08 GMT
For me, it is a warning:

/Users/aharui/git/flex/master/flex-falcon/debugger/src/main/java/flex/tools
/debugger/cli/DebugCLI.java:487: warning: LocaleUtility is internal
proprietary API and may be removed in a future release


Maybe there is a way to turn your error into a warning?  Or a replacement
for LocaleUtility?

-Alex

On 4/27/16, 5:43 AM, "Christofer Dutz" <christofer.dutz@c-ware.de> wrote:

>Hi,
>
>
>I just implemented the Maven build for the debugger module and
>encountered a problem.
>
>
>As I configured the animal-sniffer-plugin to check the output for
>compatibility with JDK 1.6, the plugin started complaining that it's not
>possible to use DebugCLI on a 1.6 VM. The line it's complaining about is
>487:
>
>
>getLocalizationManager().setLocale(LocaleUtility.langToLocale(args[++i]));
>
>
>Seems to be incompatible to 1.6. How do we proceed here? As it's getting
>impossible to get my hands on a 1.6 VM on my Mac I would like to update
>to 1.7 as base-line Java Version, what do you think? If we can't get the
>environment, how should we support it? Or we refactor this line so it's
>compatible with 1.6.
>
>
>I'm commenting that line out for now ... we should however solve the
>problem somehow.
>
>
>Chris
>

Mime
View raw message