flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pipsisewah <ste...@vantageled.com>
Subject iOS This build is invalid
Date Thu, 18 Feb 2016 15:00:00 GMT
Hello,

I am having a problem uploading my app to the App Store.  The app was
created with Flex years ago and I have had no problems updating it in the
past.  It has been almost a year since the last update and since then, the
certificate on iTunesConnect had expired and I had changed PCs so my old
SDKs were not installed anymore.

I first needed to create the new SDK so I could compile.  I did this by
following the steps listed here:
SDK:
https://helpx.adobe.com/x-productkb/multi/how-overlay-air-sdk-flex-sdk.html

Later, when things still didnt work, I also updated the compiler using the
steps listed here:
Compiler:
https://helpx.adobe.com/flash-builder/kb/overlay-air-sdk-flash-builder.html

I went through the standard process of creating a new certificate,
provisioning file, etc. using iTunes connect and a Mac.  I created a
Development certificate and a Distribution certificate.  I tested the
Development certificate on a local iPad and it worked fine.  

I built the app using the Distribution certificate and uploaded it using
ApplicationLoader.  The upload was successful, but when I went onto
iTunesConnect, it stated "This build is invalid".

I have tried using my old SDK/Compilers (as long as they are 64bit and
above) with no luck.  I also built new ones using AIR 15, 20, and 21.  

I have contacted Apple to ask what the error was but they cannot see
anything on their end.  Any insight into why this would be happening would
be greatly appreciated.  Thank you!



--
View this message in context: http://apache-flex-development.2333347.n4.nabble.com/iOS-This-build-is-invalid-tp51612.html
Sent from the Apache Flex Development mailing list archive at Nabble.com.

Mime
View raw message