flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Schmalle <teotigraphix...@gmail.com>
Subject Re: [FlexJS] npm install flexjs
Date Mon, 28 Dec 2015 11:03:12 GMT
Just shooting in the dark but some type of Java version conflict? It seems
familiar to me like that could be a possibility.


On Mon, Dec 28, 2015 at 4:34 AM, OmPrakash Muppirala <bigosmallm@gmail.com>

> I have this working locally.   If the user has npm and Java installed on
> their machine, they can now simply do:
> *npm install flexjs -g*
> (or should it be npm install apache-flexjs -g?)
> This will download all the dependencies (which has some bugs for now, will
> get to that in a bit), register the asjsc and asjscompc files as global
> binaries.
> One issue I am currently facing is, when I do this:
> C:\Users\omuppirala\AppData\Roaming\npm\node_modules\flexjs\examples\native\USStatesMap\src>asjsc
> USStatesMap.as
> I am getting this error:
> Error: Could not find or load main class
> org.apache.flex.compiler.clients.MXMLJSC
> This looks familiar, but I am not sure what I am doing wrong.
> Any pointers?
> P.S.  I will upload this flexjs npm module as a tarball on to my personal
> site from where the rest of the folks can test.  Once we iron out all the
> kinks, I will set about publishing the module to the npm repository.
> Thanks,
> Om

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message