flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [DISCUSS] Release Apache FlexJS 0.5.0
Date Tue, 20 Oct 2015 22:37:57 GMT


On 10/20/15, 3:04 PM, "Josh Tynjala" <joshtynjala@gmail.com> wrote:

>I don't think we should rely on someone having the debugger version of
>Flash Player installed in a browser. I'm pretty sure that I only have the
>release player installed these days. I haven't debugged a SWF in a browser
>in a very long time.

I’m ok with changing this.  Does anybody know how to get FlexUnit to use
the FlashPlayer Debugger?

-Alex

>
>- Josh
>
>On Tue, Oct 20, 2015 at 2:56 PM, Alex Harui <aharui@adobe.com> wrote:
>
>>
>>
>> On 10/20/15, 12:26 PM, "Harbs" <harbs.lists@gmail.com> wrote:
>> >
>> >I’m now getting an error here:
>> >
>> >Core:
>> >
>> >clean:
>> >
>> >compile:
>> >Compiling libs/Core.swc
>> >FLEX_HOME:
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-s
>>>rc
>> >FALCON_HOME:
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/falconjx/compiler/generate
>>>d/
>> >dist/sdk
>> >Created dir:
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-s
>>>rc
>> >/frameworks/projects/Core/js/out
>> >Loading configuration:
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-s
>>>rc
>> >/frameworks/projects/Core/compile-config.xml
>> >
>> >409131 bytes written to
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-s
>>>rc
>> >/frameworks/libs/Core.swc in 3.699 seconds
>> >
>> >test:
>> >
>> >clean:
>> >
>> >compile:
>> >Compiling FlexUnitFlexJSApplication.swf
>> >FLEX_HOME:
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-s
>>>rc
>> >FALCON_HOME:
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/falconjx/compiler/generate
>>>d/
>> >dist/sdk
>> >FLEXUNIT_HOME: /Users/harbs/Documents/ApacheFlex/flex-flexunit
>> >Loading configuration:
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-s
>>>rc
>> >/frameworks/flex-config.xml
>> >
>> >135896 bytes written to
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-s
>>>rc
>> >/frameworks/projects/Core/as/tests/FlexUnitFlexJSApplication.swf in
>>3.713
>> >seconds
>> 
>>>/Users/harbs/Documents/ApacheFlex/flex-flexunit/FlexUnit4/target/flexuni
>>>t-
>> >4.3.0-20140410-as3_4.12.0.swc
>> >Warning: The definition mx.utils.ObjectUtil depended on by
>> >org.flexunit.runner.Description in the SWC
>> 
>>>/Users/harbs/Documents/ApacheFlex/flex-flexunit/FlexUnit4/target/flexuni
>>>t-
>> >4.3.0-20140410-as3_4.12.0.swc could not be found
>> >
>> 
>>>/Users/harbs/Documents/ApacheFlex/flex-flexunit/FlexUnit4/target/flexuni
>>>t-
>> >4.3.0-20140410-as3_4.12.0.swc
>> >Warning: The definition mx.utils.StringUtil depended on by
>> >flexunit.framework.AsyncTestHelper in the SWC
>> 
>>>/Users/harbs/Documents/ApacheFlex/flex-flexunit/FlexUnit4/target/flexuni
>>>t-
>> >4.3.0-20140410-as3_4.12.0.swc could not be found
>> >
>> 
>>>/Users/harbs/Documents/ApacheFlex/flex-flexunit/FlexUnit4/target/flexuni
>>>t-
>> >4.3.0-20140410-as3_4.12.0.swc
>> >Warning: The definition mx.utils.ObjectUtil depended on by
>> >flexunit.framework.Assert in the SWC
>> 
>>>/Users/harbs/Documents/ApacheFlex/flex-flexunit/FlexUnit4/target/flexuni
>>>t-
>> >4.3.0-20140410-as3_4.12.0.swc could not be found
>> >
>> 
>>>/Users/harbs/Documents/ApacheFlex/flex-flexunit/FlexUnit4/target/flexuni
>>>t-
>> >4.3.0-20140410-as3_4.12.0.swc
>> >Warning: The definition mx.utils.StringUtil depended on by
>> >flexunit.framework.Assert in the SWC
>> 
>>>/Users/harbs/Documents/ApacheFlex/flex-flexunit/FlexUnit4/target/flexuni
>>>t-
>> >4.3.0-20140410-as3_4.12.0.swc could not be found
>> >
>> >
>> >test:
>> >Created dir:
>> 
>>>/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-s
>>>rc
>> >/frameworks/projects/Core/as/tests/out
>> >Validating task attributes ...
>> >Generating default values ...
>> >Using the following settings for the test run:
>> >       FLEX_HOME:
>> 
>>>[/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-
>>>sr
>> >c]
>> >       haltonfailure: [false]
>> >       headless: [false]
>> >       display: [99]
>> >       localTrusted: [true]
>> >       player: [flash]
>> >       command: [/Applications/Safari.app/Contents/MacOS/Safari]
>> >       port: [1024]
>> >       swf:
>> 
>>>[/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-
>>>sr
>> >c/frameworks/projects/Core/as/tests/FlexUnitFlexJSApplication.swf]
>> >       timeout: [90000ms]
>> >       toDir:
>> 
>>>[/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-
>>>sr
>> >c/frameworks/projects/Core/as/tests/out]
>> >Setting up server process ...
>> >Starting server ...
>> >Opening server socket on port [1024].
>> >Waiting for client connection ...
>> >Entry
>> 
>>>[/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-
>>>sr
>> >c/frameworks/projects/Core/as/tests] already available in local trust
>> >file at [/Users/harbs/Library/Preferences/Macromedia/Flash
>> >Player/#Security/FlashPlayerTrust/flexUnit.cfg].
>> >Executing '/Applications/Safari.app/Contents/MacOS/Safari' with
>>arguments:
>> 
>>>'/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/apache-flex-flexjs-0.5.0-
>>>sr
>> >c/frameworks/projects/Core/as/tests/FlexUnitFlexJSApplication.swf'
>> >
>> >The ' characters around the executable and arguments are
>> >not part of the command.
>> >
>> >
>> >Stopping server ...
>> >End of test data reached, sending acknowledgement to player ...
>> >Closing client connection ...
>> >Closing server on port [1024] ...
>> >
>> >BUILD FAILED
>> >/Users/harbs/Documents/ApacheFlex/FlexJS0.5.0/ApproveFlexJS.xml:381:
>>The
>> >following error occurred while executing this line:
>>
>> Hmm.  For me, my console looks more like:
>>
>>  [flexunit]
>>  [flexunit] Opening server socket on port [1024].
>>  [flexunit] Waiting for client connection ...
>>  [flexunit] Client connected.
>>  [flexunit] Setting inbound buffer size to [262144] bytes.
>>  [flexunit] Receiving data ...
>>  [flexunit] Sending acknowledgement to player to start sending test data
>> ...
>>  [flexunit]
>>  [flexunit]
>>  [flexunit] Stopping server ...
>>  [flexunit] End of test data reached, sending acknowledgement to player
>>...
>>  [flexunit] Closing client connection ...
>>  [flexunit] Closing server on port [1024] ...
>>  [flexunit] Analyzing reports ...
>>
>>
>>
>> So it appears the client never connected.  Did the browser show up and
>>did
>> it try to show a SWF?  Maybe you need a debugger player in the browser
>>as
>> well?
>>
>> -Alex
>>
>>

Mime
View raw message