flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mscharp <michael.sch...@fmr.com>
Subject Re: AW: AW: AW: AW: AW: FlexMojos with RSLs
Date Fri, 09 Oct 2015 16:34:26 GMT
Hey Chris, just found an interesting issue/situation.

So, to test the new snapshot I deleted my org.apache.flex folder from my
local maven repository.  I ran my build and everything worked great!  I then
tried to build on my CI server and for other reasons got an error.  But that
lead me to realize I didn't delete the flashplayer from my local maven
repository when I tested the new snapshot.

So, I deleted the flashplayer from my local repo, but left the flex
artifacts since I had already tested that.  In that configuration ( flex
artifacts can be resolved, but not the flash artifacts ) the build fails. 
Looks like a proxy error.

I looked at the code and saw that the proxy settings are only being
configured/set in the initFlex() method which is only executed if the flex
artifacts cannot be resolved.  I suggest the proxy info should be set as
soon as the plugin begins to execute, perhaps in the init() method in
FlexEventSpy?  This way, regardless of what can or cannot be resolved, the
proxy information is available for everything.

View this message in context: http://apache-flex-development.2333347.n4.nabble.com/FlexMojos-with-RSLs-tp48944p49526.html
Sent from the Apache Flex Development mailing list archive at Nabble.com.

View raw message