flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: SDK Installer trouble
Date Wed, 02 Sep 2015 15:26:53 GMT
Hi Nick,

Thanks for digging into this.  FWIW, the flex-sdk download.xml ant script
currently uses closer.cgi.  The FlexJS install script uses
http://www.apache.org/dyn/mirrors/mirrors.cgi.  If infra has shut off
mirrors.cgi then we have more work to do, although we already hit
mirrors.cgi with an “asjson” parameter as opposed to the “as_json”
parameter Infra is now suggesting.  Is Infra blocking the old asjson
parameter?

Before we put everything on hold to try to create another Installer
release, is there any way we can redirect our single-mirror-url.cgi to
some other URL?  I don’t know if the .htaccess files kick in first, or if
we can fix the installer by changing the sdk-installer-config-4.0.xml to
point to a single-mirror-url.lua or something like that.  AFAICT, the
installer picks up the URL of single-mirror-url.cgi from the
sdk-installer-config-4.0.xml file.

-Alex


On 9/2/15, 7:11 AM, "Nicholas Kwiatkowski" <nicholaskwiatkowski@gmail.com>
wrote:

>Infra has put in a temporary fix for this.  Everything should be working
>again.
>
>They have asked us to switch to a system that can parse JSON.  The JSON
>call will call the new LUA script which helps them out.
>
>It looks like we will have to fix the installer badge and the installer
>itself.  I don't think anything else depends on the CGI on our server
>(somebody correct me if I'm wrong).  The new URL to parse would be
>http://flex.apache.org/single-mirror-url.cgi?as_json=1
>
>-Nick
>
>On Wed, Sep 2, 2015 at 9:40 AM, Nicholas Kwiatkowski <
>nicholaskwiatkowski@gmail.com> wrote:
>
>> I'm working with infra to see what is going on.  We are not the only
>> project to report it, it seems.
>>
>> -Nick
>>
>> On Wed, Sep 2, 2015 at 8:09 AM, Tom Chiverton <tc@extravision.com>
>>wrote:
>>
>>> Yes, I am afraid so.
>>>
>>> They have made changes to how the mirror URLs are retrieved.
>>> It looks like we will need to change the installer to replace .cgi with
>>> .lua in the call, and also tidy up whatever is causing the HTML
>>>comment to
>>> appear.
>>>
>>> In the mean time, you should be able to install using Ant (instructions
>>> on the help page linked from the side of the installer Flash app).
>>>
>>> Tom
>>>
>>> On 02/09/15 12:30, Harbs wrote:
>>>
>>>> Is this a problem with the Apache mirror setup?
>>>>
>>>
>>>
>>

Mime
View raw message