flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mihai Chira <mihai.ch...@gmail.com>
Subject Re: [jira] [Comment Edited] (FLEX-34807) TLF - EditManager - TextFlowEdit -insertTextScrap
Date Tue, 22 Sep 2015 10:55:30 GMT
I somehow managed to get two test functions running correctly (for
some reason, the third one fails with a fatal - see below [1]). It
would really help if you took a look at the test (just committed) to
see if I started in the right direction. For now I'm just checking the
plain text result, not formatting (will follow).

It seems that there is a regression even at this stage: if my test
code is correct, then when pasting "...<i>Hello<b> world</b>!</i>...",
a new line is inserted at the end of the pasted code, as such:

EXPECTED: "There...Hello world!... are many such..."
ACTUAL: "There...Hello world!...
 are many such..."

[1] at UnitTest.ExtendedClasses::VellumTestCase/setUpFlowForTest()[C:\Users\evolverine\workspace\tlf\automation_core\src\UnitTest\ExtendedClasses\VellumTestCase.as:639]
at UnitTest.ExtendedClasses::VellumTestCase/importContent()[C:\Users\evolverine\workspace\tlf\automation_core\src\UnitTest\ExtendedClasses\VellumTestCase.as:634]
at UnitTest.ExtendedClasses::VellumTestCase/loadTestFile()[C:\Users\evolverine\workspace\tlf\automation_core\src\UnitTest\ExtendedClasses\VellumTestCase.as:700]
at UnitTest.ExtendedClasses::VellumTestCase/setUpTest()[C:\Users\evolverine\workspace\tlf\automation_core\src\UnitTest\ExtendedClasses\VellumTestCase.as:221]
at UnitTest.Tests::FLEX_34807_Test/setUpTest()[C:\Users\evolverine\workspace\tlf\automation_tests\src\UnitTest\Tests\FLEX_34807_Test.as:70]
at Function/http://adobe.com/AS3/2006/builtin::apply()
at flex.lang.reflect::Method/apply()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/flex/lang/reflect/Method.as:233]
at org.flexunit.runners.model::FrameworkMethod/invokeExplosively()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/org/flexunit/runners/model/FrameworkMethod.as:190]
at org.flexunit.internals.runners.statements::InvokeMethod/evaluate()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/org/flexunit/internals/runners/statements/InvokeMethod.as:61]
at org.flexunit.internals.runners.statements::SequencerWithDecoration/executeStep()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/org/flexunit/internals/runners/statements/SequencerWithDecoration.as:89]
at org.flexunit.internals.runners.statements::StatementSequencer/handleChildExecuteComplete()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/org/flexunit/internals/runners/statements/StatementSequencer.as:130]
at org.flexunit.internals.runners.statements::StatementSequencer/evaluate()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/org/flexunit/internals/runners/statements/StatementSequencer.as:98]
at org.flexunit.internals.runners.statements::RunBeforesInline/evaluate()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/org/flexunit/internals/runners/statements/RunBeforesInline.as:86]
at org.flexunit.internals.runners.statements::RunAftersInline/evaluate()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/org/flexunit/internals/runners/statements/RunAftersInline.as:93]
at org.flexunit.internals.runners.statements::StackAndFrameManagement/handleTimerComplete()[/Users/justinmclean/Documents/flex-flexunit/FlexUnit4/src/org/flexunit/internals/runners/statements/StackAndFrameManagement.as:127]
at flash.events::EventDispatcher/dispatchEventFunction()
at flash.events::EventDispatcher/dispatchEvent()
at flash.utils::Timer/tick()

On 22 September 2015 at 12:31, Mihai Chira <mihai.chira@gmail.com> wrote:
> It's not that. The whole of Firefox shuts down (without warning, as if
> I had closed it), not just the plugin. Same after changing the setting
> you suggested. (I have the latest version of Firefox and of the Flash
> content debugger.)
> Do you know how I can use the projector debugger instead?
>
> On 22 September 2015 at 12:06, Harbs <harbs.lists@gmail.com> wrote:
>> You probably have the timeout set in Firefox and need to disable it. Check this:
>> https://support.mozilla.org/en-US/questions/705051
>>
>> On Sep 22, 2015, at 12:44 PM, Mihai Chira <mihai.chira@gmail.com> wrote:
>>
>>> That's great to know, Piotr. Yes, I was debugging using ant, and with
>>> Alex's suggestion (thanks!) I could get the test to run in Firefox, to
>>> which I could connect with a remote debugging session. The problem is,
>>> most times the browser simply shuts down in the middle of debugging,
>>> which isn't a way forward.
>>> Could you please tell me how to get the content debugger to run the test?
>>>
>>> On 21 September 2015 at 21:35, piotrz <piotrzarzycki21@gmail.com> wrote:
>>>> Mihai,
>>>>
>>>> As I understand you are running these test using ant ? Another option is
>>>> running tests in Flash content debugger in Intellij. The question is how
did
>>>> you try run your tests ?
>>>>
>>>> Piotr
>>>>
>>>>
>>>>
>>>> -----
>>>> Apache Flex PMC
>>>> piotrzarzycki21@gmail.com
>>>> --
>>>> View this message in context: http://apache-flex-development.2333347.n4.nabble.com/Fwd-jira-Comment-Edited-FLEX-34807-TLF-EditManager-TextFlowEdit-insertTextScrap-tp49072p49281.html
>>>> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>>

Mime
View raw message