flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: New installer failures
Date Thu, 02 Jul 2015 14:32:23 GMT

On 7/2/15, 12:22 AM, "Justin Mclean" <justin@classsoftware.com> wrote:

>> Can I assume we’ve never seen this error before?
>There been a few instances of the same string, but given it’s generic
>nature it’s hard to tell if it’s the same error or not.
>There is a spike in the numbers of this error in the last few days so I
>think we can assume it’s the new installer.

Most likely.  Although there is a chance that there is a spike in the
conditions that produce this situation.  Again, in my snooping through the
SWF, I don’t really see how we could ever see just “Error”.  How does GA
handle spaces and newlines (\n) in the URL?  It looks like we pass it to
mx:HTML which I assume encodes it?  Do other tracking URLs show spaces and
newlines (\n)?

>> Did any other errors go away?
>Not all of them no, but the windows directory issue is certainly less
>than before but not gone, but I assume that this is because not every one
>is using the new installer yet. Overall error rate is slightly higher.

In looking at the logs, is this the first release with the new logic that
test write-access to the temp directory?  What does the tracker report, if
anything, once we now tell the user that they don’t have write access?
Could we be trading the old windows directory error message for this one?

>> A third place is in the uncaught error handler, but it would require
>> someone throwing an Error with the error string “Error” and the stack
>> trace not being invisible.
>Running on older AIR versions perhaps??? Another thing we could possible

Maybe, but I thought we were using captive runtime.  Although I do see
"upgrade AIR" messages when I run the installer.  Maybe someone can make
sure we are building the Installer correctly.


View raw message