flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mscharp <michael.sch...@fmr.com>
Subject Re: AW: AW: AW: Problems Installing Flash SDK according to documentation
Date Thu, 16 Jul 2015 21:06:54 GMT
I've finally had a chance to get outside of my company proxy and try this
out.  I made better progress, but still failing to build.  I did see a
couple of things that I thought might be worth mentioning, in addition to
the ultimate failure.

I noticed that it tried to install items twice.  For example, I got the 

[INFO]  - Installing Apache Flex SDK 4.14.1
===========================================================
Downloading
http://archive.apache.org/dist/flex/4.14.1/binaries/apache-flex-sdk-4.14.1-bin.zip
Expected size: 68MB
  100% [=================================================] 

and then later it tried to download/install it again.  Is there a "retry"
built in?  I did notice that before it went through this (whole) process a
second time, I received this warning (which leads to my failure to build):

[INFO]  - Finished installing Adobe Fontkit libraries
[DEBUG] Verifying availability of
/Users/me/.m2/repository/com/adobe/fontkit/1.0/fontkit-1.0.pom from [central
(https://repo.maven.apache.org/maven2, default, releases), rso
(http://repository.sonatype.org/content/groups/flexgroup/, default,
releases+snapshots)]
[WARNING] The POM for com.adobe:fontkit:jar:1.0 is missing, no dependency
information available

Also, if the project fails to build, and therefore fails to install the
downloaded artifacts into the local repository, subsequent rebuilds will
download the sdk zip file again and again.  Maybe the mavenizer could check
the temp directory for the downloaded zip file and use it instead of
downloading the zip again?

The ultimate failure was this:

[INFO]  - Finished installing Adobe Fontkit libraries
[DEBUG] Verifying availability of
/Users/me/.m2/repository/com/adobe/fontkit/1.0/fontkit-1.0.jar from [central
(https://repo.maven.apache.org/maven2, default, releases), rso
(http://repository.sonatype.org/content/groups/flexgroup/, default,
releases+snapshots)]
[DEBUG] Looking up lifecyle mappings for packaging swf from
ClassRealm[maven.ext, parent: ClassRealm[plexus.core, parent: null]]
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[ERROR] Unresolveable build extension: Plugin
net.flexmojos.oss:flexmojos-maven-plugin:7.1.0-SNAPSHOT or one of its
dependencies could not be resolved: The following artifacts could not be
resolved: org.apache.flex:compiler:pom:4.14.1, com.adobe:fontkit:jar:1.0:
Failure to find org.apache.flex:compiler:pom:4.14.1 in
https://repo.maven.apache.org/maven2 was cached in the local repository,
resolution will not be reattempted until the update interval of central has
elapsed or updates are forced @ 
[ERROR] Unknown packaging: swf @ line 28, column 16


So, looks like there are still two issues I'm dealing with.  The first is
the proxy issue.  As I mentioned, I do have the proxy settings configured in
my settings.xml file that is in my maven/conf directory.  It does not
currently have a username or password configured, although to test, I did
try it with my LAN username/password configured.  It didn't work that way
either.  

The second is this new issue.

Thanks Chris!



--
View this message in context: http://apache-flex-development.2333347.n4.nabble.com/Problems-Installing-Flash-SDK-according-to-documentation-tp48319p48535.html
Sent from the Apache Flex Development mailing list archive at Nabble.com.

Mime
View raw message