flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Schmalle <teotigraphix...@gmail.com>
Subject Re: [FlexJS] IntelliJ Integration
Date Wed, 13 May 2015 23:12:28 GMT
I am really hoping we can get this working in IntelliJ.

When I signed that "petition" for FlexJS integration, the dev basically
said you should be able to run it with external tools easily. Well right
now this is not the case.

IntelliJ is so powerful having actionscript/mxml and javascript sitting
right next to each other and being able to use that IDE to develop this
framework for myself with not that much time is a must.

If JetBrains can't get on this, Alex, this is exactly why Fred and I would
do a plugin. You set the SDK, we have some wizard, the plugin targets the
compiler and BAM it just works, just like Randori.

This part is huge for any type of adoption of this framework. We can't have
people down the road running external tools if we really want any type of
adoption and I know most use IntelliJ of some flavor to do this type of
stuff (WebStorm etc).

I am only writting this garbage because we had Randori and FlaconJX with
custom error/warning panes, configs, so much good stuff in the IDE it makes
me sad right now we are messing with external tools.

Fred just called the compiler, we dealt with the results and viola, instant
cross compile.

Now that I have FlexJS built and am in IntelliJ, I really think we are
going to have to work with them on this because the fact the MXML is messed
up gives me the feeling there is something internal going on in the MXML
plugin they wrote.

Anyway, rant over.

Mike



On Wed, May 13, 2015 at 6:54 PM, Alex Harui <aharui@adobe.com> wrote:

> I’m changing the subject in hope that the IntelliJ folks who watch this
> list might see it.
>
> It appears that some API signatures have changed since Adobe donated FDB
> to Apache.  IntelliJ might be depending on the old behavior.  Which Flex
> SDK did you use to copy the FDB jars?  The DebugCLI class looks like it is
> an older version and maybe FaultAction is from a newer Flex SDK.
>
> -Alex
>
> On 5/13/15, 2:09 PM, "piotrz" <piotrzarzycki21@gmail.com> wrote:
>
> >I was googling and searching in Intellij options for change these
> >classpath,
> >but without success. :(
> >Maybe someone know how to force intellij to use custom classpath ?
> >
> >Piotr
> >
> >
> >
> >-----
> >Apache Flex PMC
> >piotrzarzycki21@gmail.com
> >--
> >View this message in context:
> >
> http://apache-flex-development.2333347.n4.nabble.com/FlexJS-Reaching-out-t
> >o-IDE-developers-to-support-FlexJS-tp32656p46478.html
> >Sent from the Apache Flex Development mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message