flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Schmalle <teotigraphix...@gmail.com>
Subject Re: [Falcon] Problems building Falcon
Date Fri, 08 May 2015 14:44:50 GMT
Those build files are scary huge. :) I couldn't even check out the sdk
yesterday, git kept barfing on some mustella copying or something. Strange
errors I have never seen before in winGIT.

I'm scared to even try getting the sdk and falcon built. :)

Mike

On Fri, May 8, 2015 at 10:31 AM, Christofer Dutz <christofer.dutz@c-ware.de>
wrote:

> Hi,
>
>
> after adjusting my FlexJS Maven artifact generation, I wanted to test a
> build. Unfortunately I needed to re-build falcon for this, but it seems
> impossible for me to do that via ant. I am always getting test-failures.
>
>
> I followed your recipe in the other thread, but the falcon "ant all" seems
> to be failing no matter what I try.
>
>
> For example I got this:
>
> unit.tests:
>     [mkdir] Created dir:
> /Users/christoferdutz/Projects/Apache/Flex/flex-falcon/compiler.tests/results
>     [junit] environment property - FLEX_HOME =
> /Users/christoferdutz/Projects/Apache/Flex/flex-sdk
>     [junit] environment property - PLAYERGLOBAL_HOME =
> /Users/christoferdutz/Devtools/Apache/apache-flex-4.14.1/frameworks/libs/player
>     [junit] environment property - PLAYERGLOBAL_VERSION = 11.1
>     [junit] environment property - TLF_HOME =
> /Users/christoferdutz/Projects/Apache/Flex/flex-tlf
>     [junit] environment property - AIR_HOME =
> /Users/christoferdutz/Devtools/Adobe/AIR 14.0
>     [junit] environment property - FLASHPLAYER_DEBUGGER =
> /Users/christoferdutz/Devtools/Adobe/Flash 14.0/Flash
> Player.app/Contents/MacOS/Flash Player Debugger
>     [junit] Running
> org.apache.flex.compiler.internal.css.CSSArrayPropertyValueTests
>     [junit] Tests run: 2, Failures: 2, Errors: 0, Skipped: 0, Time
> elapsed: 1,512 sec
>
> BUILD FAILED
> /Users/christoferdutz/Projects/Apache/Flex/flex-falcon/build.xml:82: The
> following error occurred while executing this line:
> /Users/christoferdutz/Projects/Apache/Flex/flex-falcon/compiler.tests/build.xml:100:
> Tests failed
>
>
> But I found out that it must have been related to the PLAYERGLOBA_VERSION
> as when I upgraded it to 16.0, I got past this point.
>
> Next was that all tests with a "mx" namespace in
> flex-falcon/compiler.tests/feature-tests/mxml/tags/ seem to fail:
>
>     [junit] Running mxml.tags.MXMLHTTPServiceTagTests
>     [junit] Generating test:
>     [junit] Compiling test:
>     [junit]
> -external-library-path=/Users/christoferdutz/Devtools/Apache/apache-flex-4.14.1/frameworks/libs/player/16.0/playerglobal.swc
> -library-path=/Users/christoferdutz/Projects/Apache/Flex/flex-sdk/frameworks/libs/framework.swc,/Users/christoferdutz/Projects/Apache/Flex/flex-sdk/frameworks/locale/en_US/framework_rb.swc,/Users/christoferdutz/Projects/Apache/Flex/flex-sdk/frameworks/libs/rpc.swc,/Users/christoferdutz/Projects/Apache/Flex/flex-sdk/frameworks/locale/en_US/rpc_rb.swc
> -namespace=
> http://ns.adobe.com/mxml/2009,/Users/christoferdutz/Projects/Apache/Flex/flex-sdk/frameworks/mxml-2009-manifest.xml
> /Users/christoferdutz/Projects/Apache/Flex/flex-falcon/compiler.tests/temp/MXMLHTTPServiceTagTests6077816560368214628.mxml
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'collections'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'logging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'rpc'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit] Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time
> elapsed: 1,051 sec
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'rpc'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'collections'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'collections'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'collections'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'rpc'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'core'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'rpc'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'logging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'messaging'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'styles'
>     [junit]
>     [junit] Error: Unable to resolve resource bundle 'rpc'
>     [junit]
>
> BUILD FAILED
> /Users/christoferdutz/Projects/Apache/Flex/flex-falcon/build.xml:82: The
> following error occurred while executing this line:
> /Users/christoferdutz/Projects/Apache/Flex/flex-falcon/compiler.tests/build.xml:138:
> Tests failed
>
> So I disabled them with "@Ignore".
>
> After that I got an error in "SimpleMovie.java" as "flash.simple.Movie"
> seems to be unavailable, so I commented out even that (leaving nothing
> useful at all in the class)
>
> Now I got even more failures from the flex-compiler-oem package
> complaining about missing flash.swf package missing.
>
> Ok .... so after searching where these stupid flash.swf packages come from
> I found out that it's swfutils which is copied form the Flex SDK ..
> unfortunately using the variable FLEX_SDK_HOME which I hadn't set (Didn't
> read that it was needed) unfortunately this created an empty "swfutils"
> directory and the next time I built the stuff wasn't copied (the check
> tests if the directory exists, not if it contains content) ... so after
> several hours I finally managed to build being even more fed-up with Ant.
>
> So In the end ... I had a too old playerglobal version, I didn't have the
> FLEX_SDK_HOME variable set und there were actually only 3 Tests that didn't
> work. We have to improve here. Especially implementing some checks if at
> least all variables are set and the minimum requirements are meet.
>
> Chris
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message