flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OmPrakash Muppirala <bigosma...@gmail.com>
Subject [FlexJS] Build question - JSHint, Linter
Date Wed, 27 May 2015 17:45:11 GMT
Sorry if this was asked and answered, but I am having trouble getting the
Linter and JSHint installed on my Windows machine.  The README says this:

================================================================
    *6) The JSHint utility installed by following the instructions here:
            http://www.jshint.com/install/

        JSHint will also be automatically available.  No need to change
paths or
        environment variables.  On OSX some folks had permission issues
after
        the install.  See their documentation on using -g and sudo.
================================================================

But the page http://www.jshint.com/install/ just mentions that we should
run "npm install jshint".  So, is npm a dependency for FlexJS now?

Again, with the Google Closure Linter, the README says:

================================================================
    *4) The Google Closure Linter can be found here:
            http://code.google.com/p/closure-linter/downloads/list

        Follow the instructions here to install it.  It should automatically
        make the linter available.  No need to change paths or environment
        variables.  Some folks on OSX had permission issues after the
install.
        See their support channels for assistance.
================================================================

But there are no instructions on that page.  Also, when I download the
linter, all I see is a bunch of Python files.  Again, is Python a
dependency for FlexJS.

Should we be more explicit about these dependencies in the README?

Thanks,
Om

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message