flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: AW: AW: AW: [FlexMojo] build
Date Wed, 13 May 2015 15:51:14 GMT
Ok ... thanks for the fix. I just had a look at it ... the CLI did auto-detect the platform
type, but I think your version is cooler, could you please make the CLI use this too?

Chris

________________________________________
Von: Frédéric THOMAS <webdoublefx@hotmail.com>
Gesendet: Mittwoch, 13. Mai 2015 16:59
An: dev@flex.apache.org
Betreff: RE: AW: AW: AW: [FlexMojo] build

Hi Chris,

Well, I only pushed a fix for https://issues.apache.org/jira/browse/FLEX-34839 at the moment
:-)
Can you please review it ?

Will see eventually later for FP 10.2.

Thanks,
Frédéric THOMAS

> From: christofer.dutz@c-ware.de
> To: dev@flex.apache.org
> Subject: AW: AW: AW: [FlexMojo] build
> Date: Wed, 13 May 2015 09:37:53 +0000
>
> (Taking the conversation back to the topic ;-) )
>
> Flexunit doesn't seem to be synced to Maven central. It's available from here:
> https://oss.sonatype.org/service/local/repositories/releases/content/org/flexunit/flexunit/4.1.0/
>
> I'd be glad to receive a patch ... regarding the player-download for every sdk.
> The problem was that I noticed that the compilation of the skins of a FDK would fail
no playerglobal is availalbe. As a quick solution I added the download of the minimum player
version. I agree that when building Flexmojos with tests this can be a real PITA, but I was
assuming that usually you don't download EVERY FDK we have released ;-) The usual use-case
would be to start on a system and install the version your project is using and eventually
do that stuff again when updating to a new version. The Flexmojos build is a special case
though ;-) But I could change the code if a version 10.2 or above is resolveable and to use
that in case it is ... would make things nicer ;-)
>
> I usually let the testsuite run and only deploy and commit stuff if it runs 100% ok ...
so I'm pretty sure that the code is ok. I did notice strange problems if my Air SDK used to
run the adl (or was it adg ... welll whatever is used to run the tests) was old or the Flash
Player on my path was too old. I would really like to automate that runtime problem, but at
least for flashplayer I don't have any download urls (would be great if these were in our
installer config file :-) ).
>
> With those urls I could make the test, integration in FM perfect by automatically running
the binaries fitting the global artifacts.
>
> Chris
>
> ________________________________________
> Von: Frédéric THOMAS <webdoublefx@hotmail.com>
> Gesendet: Dienstag, 12. Mai 2015 23:47
> An: dev@flex.apache.org
> Betreff: RE: AW: AW: [FlexMojo] build
>
> Hi Chris,
>
> After having fixed the internet in the hotel and adding a few repeaters, I have internet,
yeah :-) and I found the time to go further compiling FM7 and running the test suite, what
I haven't done since a while and the mavenizer helped a lot I have to admit despite:
>
> 1- The bug I mentionned previously, I've been fixing it harcoding what was expected directly
but will give a patch if you want ?
> (detecting the running platform and passing the right value)
>
> 2- Did FM4.1 disapear from central or I dreamt it was in ? (Happily I had a maven version).
>
> 3- It is very boring that FM ask for the licence agreement each time it needs to download
FP 10.2 for the harness, what do you think if it would be reused instead ? anything I haven't
seen that could not allow that ?
>
> 4- Tests run: 133, Failures: 117, Errors: 0, Skipped: 0, Time elapsed: 1,156.774 sec
<<< FAILURE! -> Didn't dig into to see why :-)
>
> All in all, I'm happy FM7 and the mavenizer marry well together, once again, good job.
>
> I will be able to play a bit now with FM & FlexJS before to switch back on Randori
-> maybe the future FlexJS plugin (I have to admit I've been bored to have to compile using
the external tool last weekend having in more everything in red in the IDE)
>
> Thanks,
> Frédéric THOMAS
>
> > From: christofer.dutz@c-ware.de
> > To: dev@flex.apache.org
> > Subject: AW: AW: [FlexMojo] build
> > Date: Tue, 12 May 2015 13:47:36 +0000
> >
> > Hi Frederic,
> >
> > Oh yeah ... right ... forgot about that (y/n/yes/no) stuff :-)
> > Are you eventually working on a Linux CI server? Think in that case we would have
to sort of gracefully fall back to some default (win or mac) or make it possible to manually
override the type.
> >
> > But I have to admit that I should test a little more with AIR as I have mainly tested
with Flash projects.
> >
> > Yes you are on the right branch and track.
> >
> > Chris
> >
> >
> > ________________________________________
> > Von: Frédéric THOMAS <webdoublefx@hotmail.com>
> > Gesendet: Dienstag, 12. Mai 2015 11:24
> > An: dev@flex.apache.org
> > Betreff: RE: AW: [FlexMojo] build
> >
> > Hi Chris,
> >
> > I had only few time to try to debug it last night and seen things that don't correspond
to what you are saying, so I wonder if I'm on the right branch.
> >
> > > > Actually try typing "yes" and  not just 'y'
> > > > But it shouldn't have accepted 'y' are you eventually using an outdated
version of the maven extension?
> >
> > Debugging the code, I've seen the loop on the query Yes / No Y/N upper lower, I'm
on the develop branch, am I right to be ?
> >
> > It seems to me the initAir function FlexEventSpy failed with "org.apache.flex.utilities.converter.retrievers.exceptions.RetrieverException:
You need to specify the platformType parameter for AIR SDKs." because the DownloadRetreiver.retreive()
is called without the platformType
> >
> > Can you confirm I'm on the right branch and it is up to date and check you've got
the same code [1] before I go further in debugging ?
> >
> > Thanks,
> > Frédéric THOMAS
> >
> > [1]
> > protected void initAir(String version) throws MavenExecutionException {
> >     logger.info("===========================================================");
> >     logger.info(" - Installing Adobe AIR SDK " + version);
> >     try {
> >         File localRepoBaseDir = new File(mavenSession.getLocalRepository().getBasedir());
> >         DownloadRetriever downloadRetriever = new DownloadRetriever();
> >         File sdkRoot = downloadRetriever.retrieve(SdkType.AIR, version);
> >         AirConverter converter = new AirConverter(sdkRoot, localRepoBaseDir);
> >         converter.convert();
> >     } catch (Throwable ce) {
> >         throw new MavenExecutionException(
> >                 "Caught exception while downloading and converting artifact.", ce);
> >     }
> >     logger.info(" - Finished installing Adobe AIR SDK " + version);
> > }
> >
> > > From: webdoublefx@hotmail.com
> > > To: dev@flex.apache.org
> > > Subject: RE: AW: [FlexMojo] build
> > > Date: Mon, 11 May 2015 10:31:13 +0100
> > >
> > > Hi Chris,
> > >
> > > I updated the utility repo, re-installed and copied the extension but nothing
changed, will try to find the time to dig into tonigth and eventually come back to you.
> > >
> > > Thanks,
> > > Frédéric THOMAS
> > >
> > > > From: christofer.dutz@c-ware.de
> > > > To: dev@flex.apache.org
> > > > Subject: AW: [FlexMojo] build
> > > > Date: Sun, 10 May 2015 00:42:58 +0000
> > > >
> > > > Actually try typing "yes" and  not just 'y'
> > > > But it shouldn't have accepted 'y' are you eventually using an outdated
version of the maven extension?
> > > >
> > > > Chris
> > > >
> > > > Gesendet mit meinem HTC
> > > >
> > > > ----- Reply message -----
> > > > Von: "Frédéric THOMAS" <webdoublefx@hotmail.com>
> > > > An: "dev@flex.apache.org" <dev@flex.apache.org>
> > > > Betreff: [FlexMojo] build
> > > > Datum: Sa., Mai 9, 2015 22:54
> > > >
> > > > Hi,
> > > >
> > > > I'm trying to build FM 7.1.0 SNAPSHOT with maven 3.3.1 / profile minimal
and got this, any idea ?
> > > >
> > > > Downloading: http://repository.sonatype.org/content/groups/flexgroup/net/flexmojos/oss/flexmojos-parent/7.1.0-SNAPSHOT/maven-metadata.xml
> > > > [INFO] ===========================================================
> > > > [INFO]  - Installing Adobe AIR SDK 14.0
> > > > The Adobe SDK license agreement applies to the Adobe AIR SDK. Do you want
to install the Adobe AIR SDK? Adobe AIR SDK License: http://www.adobe.com/products/air/sdk-eula.html
> > > > Do you accept (Yes/No)? Yes
> > > > [WARNING] Failed to notify spy org.apache.flex.utilities.converter.mavenextension.FlexEventSpy:
Caught exception while downloading and converting artifact.
> > > > [WARNING] The POM for com.adobe.air:compiler:pom:14.0 is missing, no dependency
information available
> > > > [INFO] ===========================================================
> > > > [INFO]  - Installing Adobe AIR SDK 14.0
> > > > The Adobe SDK license agreement applies to the Adobe AIR SDK. Do you want
to install the Adobe AIR SDK? Adobe AIR SDK License: http://www.adobe.com/products/air/sdk-eula.html
> > > > Do you accept (Yes/No)? y
> > > > [WARNING] Failed to notify spy org.apache.flex.utilities.converter.mavenextension.FlexEventSpy:
Caught exception while downloading and converting artifact.
> > > > [INFO] ------------------------------------------------------------------------
> > > > [INFO] BUILD FAILURE
> > > > [INFO] ------------------------------------------------------------------------
> > > > [INFO] Total time: 45.335 s
> > > > [INFO] Finished at: 2015-05-09T21:52:05+01:00
> > > > [INFO] Final Memory: 28M/222M
> > > > [INFO] ------------------------------------------------------------------------
> > > > [ERROR] Failed to execute goal on project flexmojos-maven-plugin: Could
not resolve dependencies for project net.flexmojos.oss:flexmojos-maven-plugin:maven-plugin:7.1.0-SNAPSHOT:
Failure to find com.adobe.air:compiler:pom:14.0 in http://repository.sonatype.org/content/groups/flexgroup/
was cached in the local repository, resolution will not be reattempted until the update interval
of rso has elapsed or updates are forced -> [Help 1]
> > > > [ERROR]
> > > > [ERROR] To see the full stack trace of the errors, re-run Maven with the
-e switch.
> > > > [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> > > > [ERROR]
> > > > [ERROR] For more information about the errors and possible solutions,
please read the following articles:
> > > > [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
> > > >
> > > > Process finished with exit code 1
> > > >
> > > >
> > > > Frédéric THOMAS
> > >

Mime
View raw message