flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dany Dhondt <archeme...@mac.com>
Subject Re: Setup for patching
Date Tue, 03 Mar 2015 09:33:03 GMT
Hi,
I found the problem. The env. file for the air sdk had a extra level. I corrected that.
Now I get a BUILD SUCCESFUL message.
Nice feeling :)

d

> Op 3-mrt.-2015, om 09:55 heeft Dany Dhondt <archemedia@mac.com> het volgende geschreven:
> 
> Hi Erik, Piotrz
> 
> Thx. for helping.
> 
> I've done quite a few things already. I used this page:
> https://cwiki.apache.org/confluence/display/FLEX/1.2+Setting+up+Manually <https://cwiki.apache.org/confluence/display/FLEX/1.2+Setting+up+Manually>
> 
> env. variables ok, installed all packages, ...
> 
> then I ran:
> ant check-compile-env
> This completed with no errors
> 
> Next I ran 
> ant main 
> which gave these errors:
> 
> 
> BUILD FAILED
> /Users/dany/Documents/ApacheFlex/source/flex-sdk/build.xml:428: The following error occurred
while executing this line:
> /Users/dany/Documents/ApacheFlex/source/flex-sdk/frameworks/build.xml:121: The following
error occurred while executing this line:
> /Users/dany/Documents/ApacheFlex/source/flex-sdk/frameworks/build.xml:394: The following
error occurred while executing this line:
> /Users/dany/Documents/ApacheFlex/source/flex-sdk/frameworks/projects/airframework/build.xml:212:
compc task failed.
> 
> Total time: 6 minutes 44 seconds
> 
> I suppose this is a cumulative error reporting and only the last line is relevant?
> 
> 
> I've looked up the corresponding lines:
> 
> flex-sdk/build.xml:428:
> <ant dir="${basedir}/frameworks">
> flex-sdk/frameworks/build.xml:121:
> <antcall target="airframework"/>
> flex-sdk/frameworks/build.xml:394
> <ant dir="${basedir}/projects/airframework"/>
> flex-sdk/frameworks/projects/airframework/build.xml:212
> output="${FLEX_HOME}/frameworks/libs/air/airframework.swc">
> 
> 
> Any suggestions?
> 
> 
> d
> 
>> Op 3-mrt.-2015, om 09:08 heeft Erik de Bruin <erik@ixsoftware.nl> het volgende
geschreven:
>> 
>> Hi Dany,
>> 
>> Great to see you give this a go.
>> 
>> To get started, you have to:
>> 
>> - follow the instructions in the README to 'build the SDK from
>> source': this will build the SWCs that actually make up the SDK that
>> FB uses
>> - once complete, the SDK is ready to use in FB. In the preferences,
>> add the SDK to the list (just type 'sdk' in the search box of the
>> preferences will bring you to the item). Then simply start a new
>> project, or change a new project to use the newly added SDK...
>> - if you make changes to the SDK and want to test them in FB you have
>> to rebuild the SWC for the project you're working on AFTER EACH
>> CHANGE: the easiest to do this is to use Terminal, navigate to the
>> project ([SDK]/frameworks/projects/[project]) and execute an 'ant
>> main'. Make sure you do a 'Project/clean...' in the FB menu to get the
>> compiler to use the newly build SWC.
>> 
>> HTH,
>> 
>> EdB
>> 
>> 
>> 
>> On Tue, Mar 3, 2015 at 8:55 AM, Dany Dhondt <archemedia@mac.com> wrote:
>>> Hi,
>>> 
>>> Can someone tell me how to setup FB for working with the repository sdk please?
>>> 
>>> - I've cloned the repository with terminal.
>>> - I've checked out to develop branch
>>> - I want to make a patch
>>> 
>>> How do I setup Flash Builder at this stage?
>>> Do I have to add the flex-sdk folder somewhere?
>>> 
>>> Thx for helping out
>>> 
>>> Dany
>>> 
>>> 
>> 
>> 
>> 
>> -- 
>> Ix Multimedia Software
>> 
>> Jan Luykenstraat 27
>> 3521 VB Utrecht
>> 
>> T. 06-51952295
>> I. www.ixsoftware.nl
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message