flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [Installer] Installation aborted
Date Mon, 09 Feb 2015 20:48:05 GMT
SVN history shows some patterns that supposedly work correctly.  I just
updated to those.  Give it a try.

On 2/9/15, 11:48 AM, "OmPrakash Muppirala" <bigosmallm@gmail.com> wrote:

>Alex, any guess as to what could be happening here?
>
>Thanks,
>Om
>
>On Mon, Feb 9, 2015 at 12:45 AM, OmPrakash Muppirala
><bigosmallm@gmail.com>
>wrote:
>
>> I added the attributes version="17.0b" versionID="17.0b"
>>
>> That doesn't seem to have fixed it.
>>
>> Thanks,
>> Om
>>
>> On Mon, Feb 9, 2015 at 12:11 AM, OmPrakash Muppirala
>><bigosmallm@gmail.com
>> > wrote:
>>
>>> On Mon, Feb 9, 2015 at 12:00 AM, Alex Harui <aharui@adobe.com> wrote:
>>>
>>>> The call stack shows it is an <equals> tag.  You can use the
>>>>expressions
>>>> window to view a tag instance’s xml property to see which tag it is.
>>>>
>>>> In this case, it is:
>>>>
>>>> <equals arg1="${flash.sdk.swfversion}"
>>>> arg2="${flash.sdk.default.swfversion}"/>
>>>>
>>>>
>>>>
>>>> It appears that the install script is expecting the versionID in the
>>>> installer config to be 17.0b
>>>>
>>>>
>>> I see that "version" is set to 17.0.  Should that be changed to 17.0b ?
>>>
>>> Thanks,
>>> Om
>>>
>>>
>>>> -Alex
>>>>
>>>> On 2/8/15, 11:18 PM, "OmPrakash Muppirala" <bigosmallm@gmail.com>
>>>>wrote:
>>>>
>>>> >Okay, I got the same error during a debug run as well.  Here is the
>>>> stack
>>>> >trace:
>>>> >
>>>> >TypeError: Error #1009: Cannot access a property or method of a null
>>>> >object
>>>> >reference.
>>>> >at
>>>>
>>>> 
>>>>>org.apache.flex.ant::Ant/getValue()[C:\p\flexroot\git\flex-utilities\a
>>>>>nt_o
>>>> >n_air\src\org\apache\flex\ant\Ant.as:216]
>>>> >at
>>>>
>>>> 
>>>>>org.apache.flex.ant.tags.supportClasses::TagHandler/getAttributeValue(
>>>>>)[C:
>>>>
>>>> 
>>>>>\p\flexroot\git\flex-utilities\ant_on_air\src\org\apache\flex\ant\tags
>>>>>\sup
>>>> >portClasses\TagHandler.as:73]
>>>> >at org.apache.flex.ant.tags::Equals/get
>>>>
>>>> 
>>>>>arg1()[C:\p\flexroot\git\flex-utilities\ant_on_air\src\org\apache\flex
>>>>>\ant
>>>> >\tags\Equals.as:43]
>>>> >at
>>>>
>>>> 
>>>>>org.apache.flex.ant.tags::Equals/getValue()[C:\p\flexroot\git\flex-uti
>>>>>liti
>>>> >es\ant_on_air\src\org\apache\flex\ant\tags\Equals.as:64]
>>>> >at
>>>>
>>>> 
>>>>>org.apache.flex.ant.tags::Not/getValue()[C:\p\flexroot\git\flex-utilit
>>>>>ies\
>>>> >ant_on_air\src\org\apache\flex\ant\tags\Not.as:48]
>>>> >at org.apache.flex.ant.tags::Condition/get
>>>>
>>>> 
>>>>>computedValue()[C:\p\flexroot\git\flex-utilities\ant_on_air\src\org\ap
>>>>>ache
>>>> >\flex\ant\tags\Condition.as:63]
>>>> >at
>>>>
>>>> 
>>>>>org.apache.flex.ant.tags::Condition/execute()[C:\p\flexroot\git\flex-u
>>>>>tili
>>>> >ties\ant_on_air\src\org\apache\flex\ant\tags\Condition.as:48]
>>>> >at
>>>>
>>>> 
>>>>>org.apache.flex.ant.tags::Target/processSteps()[C:\p\flexroot\git\flex
>>>>>-uti
>>>> >lities\ant_on_air\src\org\apache\flex\ant\tags\Target.as:168]
>>>> >at
>>>>
>>>> 
>>>>>org.apache.flex.ant::Ant/doCallback()[C:\p\flexroot\git\flex-utilities
>>>>>\ant
>>>> >_on_air\src\org\apache\flex\ant\Ant.as:137]
>>>> >at
>>>>
>>>> 
>>>>>InstallApacheFlex/enterFrameHandler()[C:\p\flexroot\git\flex-utilities
>>>>>\ins
>>>> >taller\src\InstallApacheFlex.mxml:1847]
>>>> >
>>>> >
>>>> >Looks like there is some problem in parsing a particular tag.
>>>> >
>>>> >Thanks,
>>>> >Om
>>>> >
>>>> >
>>>> >On Sun, Feb 8, 2015 at 10:14 PM, OmPrakash Muppirala
>>>> ><bigosmallm@gmail.com>
>>>> >wrote:
>>>> >
>>>> >>
>>>> >>
>>>> >> On Sun, Feb 8, 2015 at 10:06 PM, Justin Mclean
>>>> >><justin@classsoftware.com>
>>>> >> wrote:
>>>> >>
>>>> >>> Hi,
>>>> >>>
>>>> >>> > Are you still getting that error?
>>>> >>>
>>>> >>> Yes.
>>>> >>>
>>>> >>> >  I looked at the google analytics report and I dont see
it being
>>>> >>> widespread.
>>>> >>>
>>>> >>> I don't think it's being reported in the google analytics.
>>>> >>>
>>>> >>>
>>>> >> Okay, I will run it through the debugger and see what's happening.
>>>> >>
>>>> >> Thanks,
>>>> >> Om
>>>> >>
>>>> >>
>>>> >>> Justin
>>>> >>
>>>> >>
>>>> >>
>>>>
>>>>
>>>
>>

Mime
View raw message