flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [DISCUSS] Release Apache Flex SDK Installer 3.2
Date Thu, 05 Feb 2015 16:02:44 GMT
Hi Neil,

AIUI, the quantity of checkboxes should be the same after switching
languages, and for a recent release like 4.14, the text for each checkbox
should match what is pulled from the apache-flex-sdk-installer-config.xml
for that release.  4.14’s is here [1], 4.13’s is here [2]:

The installer has two major code paths.  The “legacy” code path assumes a
particular set of checkboxes that is coded into the source.  The “new”
code path derives the set of checkboxes from these .xml files. I imagine
what we are seeing is that on a language change you end up back in the
legacy code path’s set of checkboxes, instead of pulling new text from the
.xml file.




On 2/5/15, 7:36 AM, "Neil Madsen" <lists@cranialinteractive.com> wrote:

>If you have a list of checkboxes that should be on the license screen for
>v4.14.0 I can at least try and get that part fixed up. As for the SDK not
>being able to be used it could stem from this if there are bits that are
>loaded that didn't need to be and vice versa. Once this is updated it may
>fix that issue as well.
>I haven't come across that issue but it may be caused by the additional
>checkboxes appearing after the language change.
>-----Original Message-----
>From: Justin Mclean [mailto:justin@classsoftware.com]
>Sent: February-05-15 1:40 AM
>To: dev@flex.apache.org
>Subject: Re: [DISCUSS] Release Apache Flex SDK Installer 3.2
>> Once I change language I see:
>> http://images.devs-on.net/Image/qJZ5xeUiPfgyTChe-Obszar.png
>Yes and even worse if you now continue from this point it makes an SDK
>doesn't work.
>I've raised this issue on the list recently but other PMC members didn't
>think it would occur enough to be considered an issue.

View raw message