flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mihai Chira <mihai.ch...@gmail.com>
Subject Re: Using source version as current Flex SDK
Date Thu, 04 Dec 2014 20:24:00 GMT
Ok, I'm giving up for today.

I managed to get makeApacheFlexForIDE.bat running after I commented
out the copying task. But now that the AIR sdk seems to be all right
too, I still get the same error when compiling with IntelliJ.

So is everyone doing it the import projects way, then?

On 4 December 2014 at 20:12, Mihai Chira <mihai.chira@gmail.com> wrote:
> Update: after commenting out the PackageMXP target, the "ant
> -Dbuild.number=20141204 -Dbuild.noprompt=release" command worked, but
> the compilation fails with the same error: "The definition of base
> class Error was not found."
> Alex, after that I also did an "ant main", which was successful, but
> now the compilation fails with "Error:[project-name]: Invalid version
> specified, ''"
> Now, I'm happy to do a release build again, but after that the piece
> that I see missing is the correct AIR SDK, which I suspect is the
> reason for the error. And the script that I see downloads it is
> makeApacheFlexForIDE.bat, right? Well, if I run it like this:
> "makeApacheFlexForIDE.bat "c:\Users\evolverine\workspace\sdk", it
> fails with this message:
> __________________________
> Copying the Apache Flex SDK from ..\.. to "c:\Users\evolverine\workspace\sdk"
> Cannot perform a cyclic copy
> 0 File(s) copied
> Exiting: error 4"
> __________________________
> which, upon checking why, makes sense - it's trying to copy a folder
> on top of itself. So the script wasn't meant for putting the AIR SDK
> (and other IDE requirements) in the same folder as the source
> distribution?
> On 4 December 2014 at 19:32, Alex Harui <aharui@adobe.com> wrote:
>> Mihai,
>> I don’t think you need to run the “release” target.  The “main” target
>> should be sufficient.  And thus you shouldn’t need the MXP tools and can
>> probably take them out of your environment variables.
>> -Alex
>> On 12/4/14, 11:23 AM, "Mihai Chira" <mihai.chira@gmail.com> wrote:
>>>Update: running ant -Dbuild.number=20141204 -Dbuild.noprompt=release
>>>failed at the PackageMXP target in
>>>frameworks\projects\flash-integration\build.xml:159 with this as the
>>>only information:
>>>     [echo] ADOBE_EXTENSION_MANAGER is c:\Program Files
>>>(x86)\Adobe\Extension Manager 5\Adobe Extension Manager CS5\Adobe
>>>n Manager CS5.exe
>>>     [echo] Creating MXP file
>>>    [mkdir] Created dir:
>>>c:\Users\evolverine\workspace\sdk\build.xml:393: The following error
>>>occurred while executing this line:
>>>c:\Users\evolverine\workspace\sdk\frameworks\build.xml:126: The
>>>following error occurred while executing this line:
>>>c:\Users\evolverine\workspace\sdk\frameworks\build.xml:441: The
>>>following error occurred while executing this line:
>>>The following error occurred while executin
>>>g this line:
>>>The following error occurred while executin
>>>g this line:
>>>exec returned: 5
>>>Total time: 5 minutes 33 seconds
>>>I took a look at what it was doing, and ran it manually with this command:
>>>$ "c:\Program Files (x86)\Adobe\Extension Manager 5\Adobe Extension
>>>Manager CS5\Adobe Extension Manager CS5.exe" -suppress -package
>>>this worked (i.e. FlexComponentKit.mxp appeared in the
>>>frameworks\flash-integration folder), but now I need to run the ant
>>>command again with the PackageMXP target commented out, so the rest of
>>>the stuff can happen...
>>>Does anyone know why the ant task might not have worked, while it
>>>works manually with the same arguments? (I am running git bash as
>>>administrator.) I couldn't find any log files in the Extension Manager
>>>install folder to see what might have happened.
>>>On 4 December 2014 at 18:54, Mihai Chira <mihai.chira@gmail.com> wrote:
>>>> Thanks for the promptitude guys.
>>>> Alex, I am working from the repos indeed.
>>>> Erik, thanks for the pointer. I'm just running ant
>>>> -Dbuild.number=20141204 -Dbuild.noprompt=release, and then following
>>>> the next steps; let's see if that helps.
>>>> Om, I think I tried that a while ago and got into a lot of trouble
>>>> because those projects in the 'frameworks/projects' folder had so many
>>>> dependencies and custom compilation flags, etc. I'm glad you could get
>>>> it to run, but I'd like to make the current source a working SDK for
>>>> the IDE.
>>>> On 4 December 2014 at 18:37, OmPrakash Muppirala <bigosmallm@gmail.com>
>>>>> The best way I know of is to point FB to a version of the SDK created
>>>>> the Flex Installer.  Then, add flex-sdk\frameworks\projects\XXXX as
>>>>> library projects in the same workspace.  Then, in your test
>>>>> add the library projects as a 'Project dependency'.  This way, you can
>>>>> continue to modify the flex library projects (i.e. editing the git repo
>>>>> directly) while making sure your test app is using your latest changes.
>>>>> Note: For the flex-sdk\frameworks\projects\textLayout Flex library
>>>>> you need to add flex-tlf\textLayout\src as a 'Source path'.
>>>>> This has worked for me reliably.  Hope this helps you with your current
>>>>> endeavor.
>>>>> Thanks,
>>>>> Om
>>>>> On Thu, Dec 4, 2014 at 10:26 AM, Mihai Chira <mihai.chira@gmail.com>
>>>>>> I want to make sure that I bug I raised in tlf is reproducible in
>>>>>> nightly source. I've never tried making the source sdk the current
>>>>>> before, and it's proving much more difficult than I thought. Here's
>>>>>> what I did:
>>>>>> >ant release (in main sdk folder)
>>>>>> after finally figuring out that I need a cfg file with the path to
>>>>>> basicLoader.swf and BasicTests.swf to run the mustella tests...
>>>>>> got error compiling: adl.exe is missing
>>>>>> >constructFlexForIDE.bat "c:\[somePath]\sdk"
>>>>>> that worked (eventually), but got this error compiling: The definition
>>>>>> of base class Error was not found.
>>>>>> >ant ide
>>>>>> same error
>>>>>> upon checking, the airglobal.swc in the installed SDK (v4.12.1) is
>>>>>> different from the one I now have in the source version (and the
>>>>>> latter is the same as the one in the Flex/AIR SDK 4.6 that it
>>>>>> downloads during the ant release target), so I thought I needed to
>>>>>> this:
>>>>>> >ide/addAIRtoSDK.sh 15.0 "c:\[somePath]\sdk" (in cygwin)
>>>>>> but couldn't get it to run because this sh file only deals with linux
>>>>>> and mac, so now I'm downloading the AIR SDK 15.0, and I'll follow
>>>>>> steps in it manually. Hopefully that will work.
>>>>>> But I have a feeling all this was too complicated. I'm probably
>>>>>> missing a much easier way to do this?
>>>>>> Thanks,
>>>>>> Mihai

View raw message