flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mihai Chira <mihai.ch...@gmail.com>
Subject Re: Using source version as current Flex SDK
Date Thu, 04 Dec 2014 18:54:49 GMT
Thanks for the promptitude guys.

Alex, I am working from the repos indeed.

Erik, thanks for the pointer. I'm just running ant
-Dbuild.number=20141204 -Dbuild.noprompt=release, and then following
the next steps; let's see if that helps.

Om, I think I tried that a while ago and got into a lot of trouble
because those projects in the 'frameworks/projects' folder had so many
dependencies and custom compilation flags, etc. I'm glad you could get
it to run, but I'd like to make the current source a working SDK for
the IDE.

On 4 December 2014 at 18:37, OmPrakash Muppirala <bigosmallm@gmail.com> wrote:
> The best way I know of is to point FB to a version of the SDK created by
> the Flex Installer.  Then, add flex-sdk\frameworks\projects\XXXX as Flex
> library projects in the same workspace.  Then, in your test application,
> add the library projects as a 'Project dependency'.  This way, you can
> continue to modify the flex library projects (i.e. editing the git repo
> directly) while making sure your test app is using your latest changes.
>
> Note: For the flex-sdk\frameworks\projects\textLayout Flex library project,
> you need to add flex-tlf\textLayout\src as a 'Source path'.
>
> This has worked for me reliably.  Hope this helps you with your current
> endeavor.
>
> Thanks,
> Om
>
> On Thu, Dec 4, 2014 at 10:26 AM, Mihai Chira <mihai.chira@gmail.com> wrote:
>
>> I want to make sure that I bug I raised in tlf is reproducible in the
>> nightly source. I've never tried making the source sdk the current sdk
>> before, and it's proving much more difficult than I thought. Here's
>> what I did:
>>
>> >ant release (in main sdk folder)
>> after finally figuring out that I need a cfg file with the path to
>> basicLoader.swf and BasicTests.swf to run the mustella tests...
>> got error compiling: adl.exe is missing
>>
>> >constructFlexForIDE.bat "c:\[somePath]\sdk" "c:\[somePath]\sdk\in\SDK_4.6"
>> that worked (eventually), but got this error compiling: The definition
>> of base class Error was not found.
>>
>> >ant ide
>> same error
>>
>> upon checking, the airglobal.swc in the installed SDK (v4.12.1) is
>> different from the one I now have in the source version (and the
>> latter is the same as the one in the Flex/AIR SDK 4.6 that it
>> downloads during the ant release target), so I thought I needed to do
>> this:
>>
>> >ide/addAIRtoSDK.sh 15.0 "c:\[somePath]\sdk" (in cygwin)
>> but couldn't get it to run because this sh file only deals with linux
>> and mac, so now I'm downloading the AIR SDK 15.0, and I'll follow the
>> steps in it manually. Hopefully that will work.
>>
>>
>> But I have a feeling all this was too complicated. I'm probably
>> missing a much easier way to do this?
>> Thanks,
>> Mihai
>>

Mime
View raw message