flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OmPrakash Muppirala <bigosma...@gmail.com>
Subject Re: new themes in 4.14
Date Wed, 10 Dec 2014 01:00:26 GMT
On Tue, Dec 9, 2014 at 1:39 PM, Alex Harui <aharui@adobe.com> wrote:

> Om, I haven’t really followed what you are doing, but is it impractical to
> create another folder next to the WireFrame and others and call it
> OldMobileTheme and keep the old theme there?
>
>
I don't think that is too hard to implement.  Lee, is that something you
want to take up?

Thanks,
Om


> -Alex
>
> On 12/9/14, 12:06 PM, "OmPrakash Muppirala" <bigosmallm@gmail.com> wrote:
>
> >On Tue, Dec 9, 2014 at 11:52 AM, Subscriptions
> ><subscriptions@leeburrows.com
> >> wrote:
> >
> >> I agree with a) and b), but disagree with the solution.
> >>
> >> However, no-on else seems bothered so i'll grudgingly submit to the
> >> general consensus ;)
> >>
> >
> >Again, you don't have to.  Help me help you :-)  Here are the various ways
> >folks could use the old skins:
> >
> >1.) Manually include an older versions of the defaults.css file to your
> >project
> >2.) We can add a new mixin that would force older skins.  User needs to
> >add
> >a compiler directive to invoke this
> >
> >I can drop this if you still want to, its up to you.
> >
> >Thanks,
> >Om
> >
> >
> >>
> >> Lee Burrows
> >> ActionScripter
> >>
> >>
> >> On 09/12/2014 19:29, OmPrakash Muppirala wrote:
> >>
> >>> Most of the feedback I had received was
> >>> a.) The old skins looked really outdated (they were from Android 2.x
> >>> period)
> >>> b.) They were creating their own skins to make it look more modern.
> >>>
> >>> Thanks,
> >>> Om
> >>>
> >>>
> >>> On Tue, Dec 9, 2014 at 11:26 AM, OmPrakash Muppirala <
> >>> bigosmallm@gmail.com>
> >>> wrote:
> >>>
> >>>  On Tue, Dec 9, 2014 at 11:21 AM, Subscriptions <
> >>>> subscriptions@leeburrows.com> wrote:
> >>>>
> >>>>  Its a shame that backwards-compatability wasn't considered important
> >>>>>
> >>>>>
> >>>>>  I think you are missing the point.  I was just trying to explain
> >>>>>what
> >>>> happened.  Of course, backwards compatibility is important.  Just
> >>>>that no
> >>>> one wanted that itch scratched till now.  The old skins have not been
> >>>> deleted.  They will still ship with 4.14.0.  It should not be too
> >>>>hard to
> >>>> make it work for those who want those old skins.  Let's try to figure
> >>>>out
> >>>> an easy way to switch it back on for those who want it.
> >>>>
> >>>> Thanks,
> >>>> Om
> >>>>
> >>>>
> >>>>  Lee Burrows
> >>>>> ActionScripter
> >>>>>
> >>>>>
> >>>>> On 09/12/2014 19:16, OmPrakash Muppirala wrote:
> >>>>>
> >>>>>  We can of course add various themes that the users can select during
> >>>>>> development, but that is outside the scope of this current endeavor,
> >>>>>> which
> >>>>>> is to update the default mobile themes so that it does not look
so
> >>>>>> outdated.
> >>>>>>
> >>>>>>
> >>>>>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message