flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: Final list of issues when running the Flexmojos testsuite with Falcon
Date Sat, 25 Oct 2014 16:14:05 GMT
And I just added the Apache Headers to my test-files ... 
they're now all in the falcon repository under my "feature/flexmojos-tests" branch in the
Apache repo.

Hope this will help the problems get sorted out sooner.

By the way ... I found a Problem in ScopeStackUnderflowProblem which seemed to have a wrong
error message referencing Operand Stack underflow errors instead of Stack Underflows.


-----Urspr√ľngliche Nachricht-----
Von: Christofer Dutz [mailto:christofer.dutz@c-ware.de] 
Gesendet: Samstag, 25. Oktober 2014 17:38
An: dev@flex.apache.org
Betreff: AW: Final list of issues when running the Flexmojos testsuite with Falcon

Ok today I have investigated more problems and added test-cases for them:
- Usage of mx:Repeater causes "operand stack underflow errors".
- Annotating an Interface with "Bindable" will cause problems.


-----Urspr√ľngliche Nachricht-----
Von: Christofer Dutz [mailto:christofer.dutz@c-ware.de] 
Gesendet: Donnerstag, 23. Oktober 2014 15:33
An: dev@flex.apache.org
Betreff: Final list of issues when running the Flexmojos testsuite with Falcon

Ok ... so now I finished going through the failled tests, I categorized them and created new
projects demonstrating each individual problem.

Here the summary of problems I found (unfortunately the list isn't really small):
- ASDoc not supported at all
- Building of Modules with MXML root fails (AS root works however)
- CSS Style with missing namespace produces NullPointerException
- SWFs with generated sources with (multiple source paths) are not executable
- Using defines for conditional compilation seems to work, accessing the value however doesn't
- Test SWFs for Air artifacts are not executable in ADL (return Error Code 9).
- Runtime loaded locales don't seem to work at all
- FontEmbedding doesn't work at all
- Image embedding doesn't work if the resources are located in a separate source path (src/main/resources)
- Apparat claims the output of Falcon not to be valid SWF files

As I posted earlier, I checked in the tests here: https://github.com/chrisdutz/flexmojos/tree/feature/falcon/test/flexmojos-tests/identified-problems

Some of these should be easy to fix, some more difficult, but I would really like to get started
in fixing them. Help greatly appreciated.

At least I now know the things I sort of have to avoid when setting up my coding demo for
ApacheCon EU


View raw message