flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: Installer broken for earlier versions of Apche Flex
Date Sat, 13 Sep 2014 04:09:23 GMT

On 9/12/14 5:15 PM, "Justin Mclean" <justin@classsoftware.com> wrote:

>>> So we would have to replace the binaries right? As that is where it
>>> the installer script from?
>> Yes.
>So we would need to branch 4.12 and 4.12.1, modify the installer.xml,
>repackage, vote and release to fix?
I suppose so, but last time I mentioned "slipstreaming" a release, some
were concerned the mirrors wouldn't pick up a modified package of the same
name.  We might have to give them new names somehow, if we go this route.
I'm still wondering if adding the "legacy" tag in
sdk-installer-config-4.0.xml will fix 4.12.x.

>I'm sure this isn't going to be the first time we get an issue like this.
>Could we have the install script check for updates and download a newer
>install script if needed?
IMO, the 4.14.0 script should work for 4.12.x.

>> I looked into this some more.  Installer 3.1.0 will use
>> sdk-installer-config-4.0.xml for 4.11 and earlier.  It doesn't explain
>> 4.11 worked and 4.10 and 4.9.1 didn't.
>4.9 and 4.10 uses OSMF 1, we don't have an alternative download path for
>that. So I'm unable to fix that unless we put the 1.0 swc somewhere we
>can get at it.
I can put OSMF1 on SF.

>> And if that works, one thing that might work for 4.12.x is to set the
>> legacy="true" attribute on their entries in the .xml file.
>I can't see why 4.12 isn't actually working as the instal script does
>have paths that should work. Is this a bug with the installer?
You sure you pulled the right tag?  That looks like the HEAD that I
modified a couple of days ago.


View raw message