flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: Migrating Flex PMD to latest PMD version
Date Sat, 06 Sep 2014 11:36:13 GMT
Ok ... so I pulled the latest PMD version and had  a look.

To me it looks as if Adobe sort of used PMD code and created defived implementations of PMD
classes in order to add Flex support. The way PMD has changed their codebase, I guess this
is no longer possible without using some really nasty hackery. But to me it looks as if we
were to add flex to PMD it would make maintaining everything a lot easier as we could directly
use the PMD infrastructure and wouldn't have to provide dedicated ant tasks and maven plugins
or reporting-plugins.

Currently PMD seems to be rather monolitic so all Languages are included inside the one and
only pmd jar ... I'll talk to them about modularizing this ... cause I think it would be great
if every language would have ist own maven module and we could simply provide one of these
modules. So if someone uses flex, he would have to add a plugin-dependency to our flex language
support module.

Hopefully they respond to posts on their mailinglist ;-)

Chris

-----Urspr√ľngliche Nachricht-----
Von: Alex Harui [mailto:aharui@adobe.com] 
Gesendet: Freitag, 5. September 2014 18:22
An: dev@flex.apache.org
Betreff: Re: Migrating Flex PMD to latest PMD version



On 9/5/14 3:32 AM, "Christofer Dutz" <christofer.dutz@c-ware.de> wrote:

>So I haven't dropped the ball ... I am just expecting to have a little 
>stall on my work here.
I'm certainly not pushing anyone to rush on this stuff.  I'm just happy you are even trying.

Thanks,
-Alex


Mime
View raw message