flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: Android OS version - Flash Builder configuration
Date Tue, 12 Aug 2014 20:12:02 GMT

On 8/12/14 12:56 PM, "OmPrakash Muppirala" <bigosmallm@gmail.com> wrote:

>I just realized that I had messed up one of run configuration parameters.
>Which is why I was getting 4.1 instead of AND for Capabilities.version.  I
>reverted that and I am getting the correct value of AND.
>However, there is still no way to tell the OS version.  I see that
>spark.utils.PlatformMobileHelper does actually read an Android system file
>to determine the version.  Obviously, this fails during simulation.
>I am going to apply your [Mixin] approach to fix this during simulation.
OK.  Bonus points if the Mixin can tell it is on the device and doesn't do
the override.  Then it won't screw over someone who forgets to remove the
compile option before deploying to the device.


View raw message