flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject [CANCEL][VOTE] Apache FlexJS 0.0.2 RC2
Date Thu, 10 Jul 2014 06:51:35 GMT
Canceling in order to pick up latest GCC and GCL.

On 6/23/14 9:25 AM, "Alex Harui" <aharui@adobe.com> wrote:

>Hi,
>
>This is vote for the second (0.0.2) release of Apache FlexJS.
>
>The release candidate can be found here;
>https://dist.apache.org/repos/dist/dev/flex/flexjs/0.0.2/rc2/
>
>Before voting please review the section,"What are the ASF requirements on
>approving a release?", at:
>http://www.apache.org/dev/release.html#approving-a-release
>
>At a minimum you would be expected to check that:
>- MD5 and signed packages are correct
>- README, RELEASE_NOTES, NOTICE and LICENSE files are all fine
>- As this is the first release please carefully check the LICENSE and
>NOTICE files
>- That the build script completes successfully
>- That you can compile and cross-compile a simple example using the SDK.
>
>The source package is set up the same way as the repo.  This means that
>the results of the build are not the same as an IDE-compatible SDK.  The
>compiled source package can be used in combination with the FalconJX
>source package to compile some of the sample applications.
>
>The most convenient way to use the binary package is to install it via Ant
>or the Installer.  To use an Installer you must use InstallApacheFlex
>version 3.1 or later which is still in release candidate status at this
>time.  You can get InstallApacheFlex 3.1 here:
>https://dist.apache.org/repos/dist/dev/flex/installer/3.1/rc4/binaries/
>
>Please vote to approve this release:
>+1 Approve the release
>-1 Veto the release (please provide specific comments to why)
>
>This vote will be open for 72 hours or until a result can be called.
>
>The vote passes if there is:
>- At least 3 +1 votes from the PMC
>- More positive votes than negative votes
>
>Remember that this is an initial 'alpha-quality' release so I expect there
>will be many bugs found.  IMO the goal is not to try to find and fix bugs
>in the RC, but to make sure we have the packaging right, and enough
>functionality that folks will have some success trying to use it.
>
>People who are not in PMC are also encouraged to test out the release and
>vote, although their votes will not be binding, they can influence how the
>PMC votes.
>
>When voting please indicate what OS, IDE, Flash Player version and AIR
>version you tested FlexUnit with.
>
>For your convenience, there is an ant script that automates the common
>steps to validate a
>release.  Instead of individually downloading the package and signature
>files, unzipping, etc, you can instead:
>1) create an empty folder,
>2) download into that folder this file:
>https://dist.apache.org/repos/dist/dev/flex/falcon/0.0.2/rc1/ApproveFlexJS
>.
>xml
>3) run the script: ant -e -f ApproveFlexJS.xml -Drelease.version=0.0.2
>-Drc=2
>
>You are not required to use this script, and more testing of the packages
>and build results are always encouraged.
>
>
>You will have to install Google Closure Linter and JSHint prior to running
>the script.
>
>Please put all discussion about this release in the DISCUSSION thread not
>this VOTE thread.
>
>Thanks,
>Alex
>
>


Mime
View raw message