flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DarkStone <darkst...@163.com>
Subject Re:Re: [DISCUSS] Release Apache Flex SDK Installer 3.1 - RC2
Date Thu, 12 Jun 2014 17:03:18 GMT
Hi Alex,

"Do you have a JAVA_HOME environment variable?"
No, I'll try to add it.

"From the command line, what does "where java" return?"
Mine retuns C:\Windows\System32\java.exe


I have finished translations for the ANT versions of Flex SDK & FlexJS, I found an obvious
error in the en_US.properties of the FlexJS:
[Line 61 about SWFObject]: This license is compatible with the Apache v2 license.\n\

I think it should be "This license is not compatible with the Apache v2 license.\n\"

I think I may finish the translations for UI version of the Flex SDK Installer in a few days.


DarkStone
2014-06-13



At 2014-06-13 00:12:01, "Alex Harui" <aharui@adobe.com> wrote:
>Interesting.  Java is required for the regular Flex SDK, but for FlexJS we
>are trying to find the path to the java executable.
>
>Do you have a JAVA_HOME environment variable?
>Is there a java.exe in the bin folder of where JAVA_HOME point to?
>From the command line, what does "where java" return?
>
>Thanks,
>-Alex
>
>On 6/12/14 6:47 AM, "DarkStone" <darkstone@163.com> wrote:
>
>>Hi Alex,
>>
>>"Please right-click and turn on verbose logging and see how far it gets."
>>I just did it, here is the log:
>>
>>Version 3.1.0 (windows)
>>Using Locale:zh_CN
>>Fetched the SDK download mirror URL from the CGI.
>>AIR version 14.0
>>Flash Player version 14.0
>>Creating Apache FlexJS home
>>Creating temporary directory
>>Downloading Apache FlexJS
>>from:http://apacheflexbuild.cloudapp.net:8080/job/flex-asjs/lastSuccessful
>>Build/artifact/out/apache-flex-flexjs-0.0.2-bin.zip
>>downloading 
>>http://apacheflexbuild.cloudapp.net:8080/job/flex-asjs/lastSuccessfulBuild
>>/artifact/out/apache-flex-flexjs-0.0.2-bin.zip
>>not caching this download
>>Verifying Apache Flex JS MD5 Signature
>>The Apache FlexJS MD5 Signature of the downloaded files matches the
>>reference. The file is valid.
>>Uncompressing: D:\Adobe\Adobe Flash Builder 4.7 (64
>>Bit)\sdks\FlexJS\temp\apache-flex-flexjs-0.0.2-bin.zip
>>Finished uncompressing: D:\Adobe\Adobe Flash Builder 4.7 (64
>>Bit)\sdks\FlexJS\temp\apache-flex-flexjs-0.0.2-bin.zip
>>      [get] Getting:
>>http://flex.apache.org/installer/properties/flexjs/en_US.properties
>>      [get] To: D:\Adobe\Adobe Flash Builder 4.7 (64
>>Bit)\sdks\FlexJS\en_US.properties
>>[IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2
>>text="Error #2032" errorID=2032]
>>
>>get-data:
>>      [get] Getting:
>>http://flex.apache.org/installer/sdk-installer-config-4.0.xml?ts=20140612
>>      [get] To: D:\Adobe\Adobe Flash Builder 4.7 (64
>>Bit)\sdks\FlexJS\sdk-installer-config-4.0.xml
>>
>>find-java-executable-windows:
>>
>>find-java-executable-others:
>>
>>search-java-windows:
>>
>>search-java-others:
>>
>>search-java:
>>
>>check-java:
>>Unable to find Java executable.  Please set JAVA_HOME environment variable
>>
>>
>>I didn't know this requires Java, but I installed JRE on my computer.
>>
>>DarkStone
>>2014-06-12
>>
>>
>>At 2014-06-12 09:38:51, "Alex Harui" <aharui@adobe.com> wrote:
>>>
>>>
>>>On 6/12/14 6:15 AM, "DarkStone" <darkstone@163.com> wrote:
>>>
>>>>Hi Alex,
>>>>
>>>>I did some tests for FlexJS, I can not complete the installations at
>>>>all.
>>>>
>>>>FlexJS 0.0.1 + AIR 14 + FP 14, install log:
>>>>
>>>>antlr3.org is totally blocked in China, we have to use maven or github.
>>>>
>>>Yes, we know about this.
>>>>
>>>>FlexJS 0.0.2 + AIR 14 + FP 14, install log:
>>>>
>>>>I tried this several times, always hanging in the "Finished
>>>>uncompressing"
>>>>step.
>>>>
>>>Please right-click and turn on verbose logging and see how far it gets.
>>>
>>>Thanks,
>>>-Alex
>>>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message