flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frédéric THOMAS <webdoubl...@hotmail.com>
Subject RE: AW: Update to BlazeDS to make Testsuite pass
Date Tue, 06 May 2014 07:52:24 GMT
In case you need it, the RAT plugin is also available for Maven.

Frédéric THOMAS

> From: christofer.dutz@c-ware.de
> To: dev@flex.apache.org
> Subject: AW: Update to BlazeDS to make Testsuite pass
> Date: Tue, 6 May 2014 07:45:27 +0000
> 
> Hmm ... ok ... 
> 
> well I didn't remove anything so I guess they were missing from the beginning.
> I agree we should add them. 
> 
> Regarding the other problems ... I was getting them too ... but from the beginning, so
I didn't change anything here. All I did was to sort out the missing directory problems on
windows and remove the junit execution stuff from core (It wasn't called from anywhere anyway).
I too was getting these errors, but I didn't understand what was actually happening outside
the "modules" directory. I tried a lot of guessing, but didn't really get far. I too was getting
the errors you are describing. At least at the end of the Ant and the Maven build all libraries
in modules are created correctly.
> 
> And for the others that want to build BlazeDS using Maven ... just to to the "modules"
directory and issue the following command:
> 
> mvn clean install
> 
> That should be all.
> 
> Chris
> 
> 
> ________________________________________
> Von: Justin Mclean <justin@classsoftware.com>
> Gesendet: Dienstag, 6. Mai 2014 00:36
> An: dev@flex.apache.org
> Betreff: Re: Update to BlazeDS to make Testsuite pass
> 
> Hi,
> 
> > Ok ... so the first BlazeDS 4.7-SNAPSHOT is now available:
> > https://repository.apache.org/content/repositories/snapshots/org/apache/flex/blazeds/
> 
> Looking at the source:
> It's missing a LICENCE and NOTICE file - they would be need before we could make a release.
Does this apply to the  SNAPSHOT as well? or does that info go into the maven xml files?
> There a few text files that may need apache headers.
> There's also a thumbs.db file can can be removed.
> 
> On OSX I was able to get it to compile (sort of) via ant - but looks like there a few
errors. If anyone want to try note that It requires ant contrib to build.
> The generate-config-files fails with a "Premature end of file" error, but the build continues.
> Also looks like a file [1] have not been checked in correctly as I getting this: "unmappable
character for encoding UTF8" right at the end of the build.
> Also looks like some of the config files (eg messaging-config.mod.xml) may have windows
newlines ^M in them - or perhaps that's git config issue?
> 
> Getting there.
> 
> Thanks,
> Justin
> 
> 1. qa/apps/qa-manual/WEB-INF/src/qa/utils/MessageGenerator.java
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message