flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: adc byte decode errors in Flash Builder 4.7
Date Thu, 15 May 2014 15:29:03 GMT

On 5/14/14 11:24 AM, "Chris Martin" <windowns@gmail.com> wrote:

>It appears that the "incremental build" functionality in Flash Builder 4.7
>is having issues when using the proxy swc files (fiber.swc and
>playerfds.swc).  I keep getting abc byte decode errors every so often.  A
>clean and rebuild fixes the problem, but with this large project it can be
>a bit of a pain.  In my research it seems people are saying that this can
>happen when included swc files are compiled with a different framework
>version than the main project.  I believe this matches what i'm seeing.
>I'm on Flex 4.12.0 and I suspect the two above mentioned swc files were
>compiled with Flex 4.5 because of their location path (C:\Program
>Files\Adobe\Adobe Flash Builder 4.7 (64
>In the fiberSwcs folder we only have two subfolders 3.6 and 4.5.
>So in the end I'm wondering if we don't have the ability to recompile
>in the latest framework.  Were they included with the donation, or Adobe
>kept these as they are really part of Flash Builder 4.7?
The fiber stuff was not donated.  I suppose we could look into it, but
then folks would have to hand-patch their FB installs.

IMO, incremental building had a history of breaking down and requiring
cleaning and rebuilding.  I don't recall any particular changes to the SWC
or ABC formats between 4.5 and now but I could be wrong.  Is the compiler
throwing the error or is it the SWF throwing the error?


View raw message